Tighten Gas Cap and Check Engine Lights - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-06-2013, 01:22 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
cclemen333 is on a distinguished road
Smile Tighten Gas Cap and Check Engine Lights

Wanted to share my recent experience.

2008 Impala SS started surging slightly at cruising speeds. I cleaned the MAF sensor. Nothing changed. The next day I get a message on the dash to Tighten Gas Cap. It wasn't loose. That afternoon the Check Engine light appeared. I double checked to make sure my hoses were reconnected properly to the air intake tube. Check. I then discovered that my remote starter (from the factory) was no longer working. Hmmm. I took it to my local Auto Zone and got the diagnostic codes of P0455 and P0121. I then took the intake hose back off the throttle body housing and sprayed TB cleaner in there while wiping out what I could with a rag. I fired up the engine (after some extra cranks to clean the cleaner out of the intake), cruised two miles down the road and the check engine light disappeared, no more message to tighten gas cap, no more surging, and the remote starter now works. Unbelievable.
I think my K&N affects this more than a paper filter would. I suspect the oils from the filter cause faster buildup on the sensing elements of the intake.
cclemen333 is offline   Reply With Quote
Old 03-06-2013, 01:35 PM   #2
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Nice find Joe. Now, set aside a nice Sunday afternoon, pull the throttle body and give it a good cleaning.
2kg4u is offline   Reply With Quote
Old 03-06-2013, 02:28 PM   #3
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

ive got a k&n on my 07 monte(same) and havent had any issues. you just got to be careful with the oil. in fact ive put them on every car and havent had any issues. FYI the gm remote start wont work with any cel no matter if its unsafe or not.
jwfirebird is offline   Reply With Quote
Old 03-06-2013, 03:30 PM   #4
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
cclemen333 is on a distinguished road
Default

Thats a good idea. Thanks.

Quote:
Originally Posted by 2kg4u View Post
Nice find Joe. Now, set aside a nice Sunday afternoon, pull the throttle body and give it a good cleaning.
cclemen333 is offline   Reply With Quote
Old 03-06-2013, 03:32 PM   #5
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
cclemen333 is on a distinguished road
Default

I didn't know that. Good info. Thanks.

Quote:
Originally Posted by jwfirebird View Post
ive got a k&n on my 07 monte(same) and havent had any issues. you just got to be careful with the oil. in fact ive put them on every car and havent had any issues. FYI the gm remote start wont work with any cel no matter if its unsafe or not.
cclemen333 is offline   Reply With Quote
Old 05-16-2013, 10:30 AM   #6
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
cclemen333 is on a distinguished road
Default

I need to add info here. I just got another CEL for P0455. I had already cleaned out the TB. So, I looked closer and noticed a line port missing a tube going into the intake just after the MAF sensor. I capped it off and drove for 50 miles and the CEL is gone. Now I just need to locate where the tube went to and reconnect. Anybody have any diagrams?
cclemen333 is offline   Reply With Quote
Old 05-16-2013, 11:30 AM   #7
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Can you take a picture and post it?
2kg4u is offline   Reply With Quote
Old 05-16-2013, 11:58 AM   #8
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
cclemen333 is on a distinguished road
Default picture of port with missing tube

[ATTACH]Tighten Gas Cap and Check Engine Lights-2013-05-16_10-49-11_41.jpg[/ATTACH]

I stuck an ear plug in the port for temporary plug
cclemen333 is offline   Reply With Quote
Old 05-16-2013, 12:07 PM   #9
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
cclemen333 is on a distinguished road
Default missing tube

That port is pointing to the firewall.
cclemen333 is offline   Reply With Quote
Old 05-20-2013, 10:57 AM   #10
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
cclemen333 is on a distinguished road
Default

Just a reminder, this is a 5.3 L V8. I am still trying to find out where this missing line goes. Anybody that has this motor please check on yours and advise if you can.
cclemen333 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
"Gas Cap Loose Check Cap" - 2001 Buick Lesabre eb-86 Buick 9 04-08-2015 01:31 PM
Gas cap error - gas spurting out fill spout scottydl Buick 32 04-01-2014 04:48 PM
Gas Cap. Don't Let others steal your gas 03SSEISUPERCHARGED General GM Chat 26 05-04-2008 09:36 PM
Check Gas Cap ChamPAIN Bonne Everything Electrical & Electronic 2 02-09-2004 08:53 PM
"check gas cap" Custom88 2000-2005 14 01-24-2004 03:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.