Hard start when warm, flashing Service Engine Soon at Idle. - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-01-2010, 12:30 AM   #11
Junior Member
Thread Starter
 
Join Date: Jun 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
KoryKreisler is on a distinguished road
Default

Daughter had softball tonight so no chance to "play" with the truck. I did get new sparkplugs and stopped by the Chevy dealer and had them read the codes. He didn't tell me the numbers but they were as follows

MAF sensor
Bank #2 running rich
Multiple Misfires

He thought that it sounded fuel related but wouldn't know for sure unless I brought it into the shop.

Dan/Bill,
I have a coil per cylinder on the truck and the spark was stong enough to jump about 1" from the coil to the plug wire. The problems I have are only when the truck is starting & idling, soon as I start driving the Service Enginge light goes off and she runs like a champ.. until the next stop...

Tomorrow afternoon I will change plugs, test the plug wires, MAF unit, and switch the #2 & #4 fuel injector and see if the non-running cylinder changes spots.

Until then thanks again for the help and wish me luck!

Kory
KoryKreisler is offline   Reply With Quote
Old 07-01-2010, 01:24 AM   #12
Junior Member
Thread Starter
 
Join Date: Jun 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
KoryKreisler is on a distinguished road
Default

One more thing before I hit the hay.

I was just doing some more searching and stumbled across something. Fuel pressure regulator, when I pulled the vaccum hose off of the regulator yesterday raw fuel came out of the vaccum line, didn't think anything of it but from what I just read that'* an indication that it'* bad and it'* sucking raw fuel into the intake. Might explain some of the problems, probably not all of them but I'll be picking one of those up on the way home tomorrow.

Kory
KoryKreisler is offline   Reply With Quote
Old 07-01-2010, 07:40 AM   #13
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Yes, change the regulator. That'll be step one that probably fixes your hard start and misfire.
BillBoost37 is offline   Reply With Quote
Old 07-01-2010, 08:09 AM   #14
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Yep, change that FPR. The diaphragm is bad and allowing fuel threw.
Danthurs is offline   Reply With Quote
Old 07-02-2010, 12:14 AM   #15
Junior Member
Thread Starter
 
Join Date: Jun 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
KoryKreisler is on a distinguished road
Default

SUCCESS! New spark plugs & fuel pressure regulator and no more Service Engine Soon lights, no more hard starts. Funny the only thing under the hood without a electrical connection seems to be what was causing the problem. I'm sure it didn't hurt to replace the MAF sensor and clean/check every thing before I got to this, but if I ever have the same problem with hard starting that vaccum hose on the fuel pressure regulator will be the first thing check.


Thanks for all the help!
Kory Kreisler
KoryKreisler is offline   Reply With Quote
Old 07-02-2010, 12:39 AM   #16
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Good to hear.
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
04 Impala rough Idle and hard warm engine starts ngehrke Chevrolet 4 03-26-2013 10:28 AM
Flashing "Service Engine Soon Light" when under hard acceleration Hesk000 2000-2005 18 10-27-2009 02:46 PM
FLASHING SERVICE ENGINE SOON LIGHT! kcoop99 2000-2005 4 01-28-2007 03:09 AM
Update - engine surges at idle when engine is warm billha 1992-1999 8 06-28-2005 12:55 PM
Service Engine Soon vs. Check Engine vital49 1992-1999 6 03-22-2004 05:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:58 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.