'95 Silvarado Extended Cab Oil Gauge Problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-16-2014, 01:22 AM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Apr 2005
Posts: 243
Thanks: 0
Thanked 3 Times in 3 Posts
dandyd is on a distinguished road
Default '95 Silvarado Extended Cab Oil Gauge Problem

My '95 Silverado P/U Oil pressure gauge is erratic..... it constantly pegs all the way over, then back down to 0, and back over etc..... occasionally it will begin to read "normally" for just a bit, then back to the erratic behavior....it'* irritating because when it goes to 0 the red dash light comes on to "Check Gauges"....... any ideas..... sending unit bad etc..... ??
dandyd is offline   Reply With Quote
Old 03-16-2014, 04:56 AM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,586
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

It sure sounds like a replacement Delco sending unit is in order.
What engine/ how many miles on your PU do u have? Is the oil on dipstick at full line?
But it sometimes can be electrical connections as well.
It may be best to hook up a mechanical pressure gauge to see where it truly is at.

Last edited by Soft Ride; 03-16-2014 at 04:57 AM.
Soft Ride is online now   Reply With Quote
Old 03-16-2014, 01:41 PM   #3
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

i think on all the engines for that one the sender for the gauge is the one by the filter and to me it sounds like that could be the issue, not a real good way i can think of than just replace it. as mentioned get a delphi or delco one (rock auto has good prices on oem stuff) just make sure the plug looks good and dont use any sealant or tape other than what may come on sensors, because the readings are based on resistance to ground which is the block electrical connection
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2008 gmc sierra extended cab w/t bryanjay08 GMC/Chevrolet Truck/SUV 13 11-15-2015 02:29 AM
RANGER DANGER!! - Brush Fire in The Cab! +pics lash Lounge 25 08-28-2007 01:04 PM
FS: 2002 Chevy Silverado Z71 Extended Cab Archon Lounge 1 05-10-2007 03:31 PM
sober cab harofreak00 Lounge 13 08-05-2006 07:12 PM
Metal Wall that seperates trunk and cab LeonardJohn 1987-1991 4 03-29-2005 10:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:03 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.