2010 SRX help - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Cadillac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-25-2011, 10:01 PM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
BTO86 is on a distinguished road
Default 2010 SRX help

My fiance bought an 2010 SRX a while back with only 20,000 miles that was a gm executive vehicle. Long story short, it intermittently goes dead at night. It is not consistent on when it does it. What i have noticed is that if the radio doesn't work (another problem) and you shut it off that way at night, it will be virtually dead the next morning. Meaning that using the remote to start it, it will crank for a half of a second then the horn will start honking. When you get in and try the push button it says no remote detected (meaning the battery is dead). There has to be a direct correlation with the radio not working then shutting it off that makes it go dead since both seem to happen in order. The dealer in Springfield IL has seen it several times already and has done a recall or service bulletin by re-flashing or re-programming it for the problem we are having. They also paid for a new battery. But, it hasn't fixed it and they just keep saying they can't find a problem. Has to be some kind of module problem. Anybody else heard of this problem with these things?
BTO86 is offline   Reply With Quote
Old 01-25-2011, 10:08 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

You have a load running and that'* killing your battery. Could be a relay stuck. Here is a write up on how to do a amp draw test. Follow it and you should be able to find the problem. It'* just a mater of hunting. https://www.gmforum.com/trouble-shooting-test-procedures-141/amp-draw-test-293647/
Danthurs is offline   Reply With Quote
Old 01-25-2011, 10:18 PM   #3
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
BTO86 is on a distinguished road
Default

I understand that there is a parasitic draw somewhere. The problem is that this thing is under warranty and after several times of having it there and them not finding anything they should get gm involved and start trying different things. As of this morning it is back at the dealer and i told them to keep it until they can duplicate the problem and asked if they had put an amp clamp on anything to check for a draw. I got that "uhhhh" look. Now they know that i'm no ordinary idiot. I work full time as a tech on heavy duty trucks (Freightliner dealer). I know that in the car world they like to change parts and send it out the door. This is why I'm getting pi$$ed with them blowing it off and not spending the time on it. Thanks for the help though. Brian
BTO86 is offline   Reply With Quote
Old 01-25-2011, 10:32 PM   #4
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Dealerships = swapnostics. Put a amp meter on, and start pulling fuses until the amps go away. If the draw is a there one time and not another. That'* a relay. I had the same problem and it was the relay on the power antenna. Pulled the relay, and no more dead battery.
Danthurs is offline   Reply With Quote
Old 01-25-2011, 11:26 PM   #5
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
BTO86 is on a distinguished road
Default

Thanks for the help. I did some searching and found an actual Cadillac forum. I did some reading and found that this has been an on-going problem with these things. Everything from software updates to a shorting fuse box by the battery. I now have some ammo to throw at the dealer tomorrow.
BTO86 is offline   Reply With Quote
Old 01-25-2011, 11:31 PM   #6
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Good luck, would love to here what the problem was.
Danthurs is offline   Reply With Quote
Old 01-25-2011, 11:40 PM   #7
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
BTO86 is on a distinguished road
Default

Ok, I'll try to remember to post it. So far those are the only things I've read the most about. Sounds like its been an epidemic.
Kind of like how the "check rear axle" comes across the display. Something in the filter is messing up causing that. The dealer changes the fluid and filter to cure the problem on certain build date ones. This should get interesting if little crap like this keeps happening with this thing.
BTO86 is offline   Reply With Quote
Old 02-10-2011, 06:18 PM   #8
Senior Member
Posts like a Northstar
 
Skippy1827's Avatar
 
Join Date: Jun 2006
Location: Waukesha, Wisconsin
Posts: 747
Thanks: 0
Thanked 0 Times in 0 Posts
Skippy1827 is on a distinguished road
Default

Any update?
I would recommend taking to a different dealer... Every dealer has their own set of techs. Not all techs got an A in class. Keep looking for a tech that knows what he/she is doing..
Skippy1827 is offline   Reply With Quote
Old 02-11-2011, 10:15 AM   #9
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Send me a PM with your VIN and I will look up your claim to see how the dealership is reporting it. I can also tell you how many claims have been submitted with the same complaint.
2kg4u is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 SRX TPS/Intake codes. Sheepish Cadillac 7 04-07-2013 01:22 PM
P0650 2009 Cadillac SRX MyRedSRX Cadillac 7 02-20-2013 11:25 AM
2010 SRX Remote Programming josephl Cadillac 5 11-13-2012 05:33 PM
2004 cadillac SRX no crank no start fullcoverage Cadillac 5 02-17-2012 11:04 AM
XLR and SRX 1992 trofeo Lounge 28 11-08-2003 01:21 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.