Rebuild or replace 93 L67 Park Ave Ultra - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-07-2012, 04:48 PM   #11
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

One more quick question, I found a 94 Park ave Ultra with 140k that was tboned, supercharged engine/trans good. Guy pulled engine,trans, wiring and computer. Can i just drop that setup into my 93. They are both OBD1 cars just the 94 has the upgraded m62 that i would prefer to have. Thanks in advance
Mr Fix It is offline   Reply With Quote
Old 11-07-2012, 04:50 PM   #12
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

I don't see why not. Just transfer all the sensors over. Sometimes they change from year to year.
Mike is offline   Reply With Quote
Old 11-07-2012, 04:59 PM   #13
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

SWEET deal thats what I wanted to hear! I planned on just dropping it all in there and off we go.
Mr Fix It is offline   Reply With Quote
Old 11-07-2012, 05:05 PM   #14
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Ya might want to replace some gaskets here and there while its out. Much easier to do!!! Been there, done that!
Mike is offline   Reply With Quote
Old 11-07-2012, 08:25 PM   #15
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

Great point. Im thinking about porting the heads/LIM on my "dead" motor and then later on put them on my "new" engine when i get it. Im thinking that what caused mine to knock was the Intake gasket, it has oil in the radiator and it smokes out the tailpipe (blue smoke). it hasnt milkshaked yet but it has barely been run since the incident, so im hoping the heads/ and such are still ok
Mr Fix It is offline   Reply With Quote
Old 11-07-2012, 10:16 PM   #16
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

Got the setup for $525, pretty decent deal I think as the local yard wanted $500 for the engine alone with 200k on it. Now time to get cracking. Picking it up tomorrow afternoon!
Mr Fix It is offline   Reply With Quote
Old 11-07-2012, 10:23 PM   #17
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

That is a good deal, just a tad more than what I would normally pay for, yet still pretty good.

Shoot some pics if you have time.
Mike is offline   Reply With Quote
Old 11-16-2012, 01:54 AM   #18
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

UPDATE: looks like this wasnt as easy as it seemed, I got the old engine and trans pulled, new one set in bolted up and everything hooked up. First had a few issues like EGR and Motor mounts that were different, got that all situated and start it up for the first time. (with the original 93 PCM and 94 engine trans) wont run more than 3-5 seconds, it dies. Ok so i unplug the MAF and wahla it runs by itself. but not well. plug MAF in and it dies. ok so i swapped MAF from original and still same issue persists. One major problem is that the 94 PCM DOES NOT plug into the 93 Wiring!! Connectors are slightly different. Next what I did was put my old 93 supercharger setup on new engine and plug everything in and it runs but still only with MAF unplugged. runs choppy as well I need a new EGR tube somehow it got broken...... anyways it also running super rich. And my ABS and TRAC off lights are lit up on dash. One thing I can think of is that i accidently broke the abs sensor wire on the pass front, so i got one at the junkyard and spliced it in. that may be the cause, but the other thing i thought of was the 94 trans had the trac off option where as my 93 DID NOT will that be an issue? Sorry for the super long post. I have spent a week on it non stop and it just refuses to give in to me. This is my first major swap from diff years of car and engine, the last engine /trans have been same year to same year etc. Im only 18 and learning as I go. Thanks for any help.
Mr Fix It is offline   Reply With Quote
Old 11-16-2012, 05:24 AM   #19
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

If the 94 PCM does not fit the wiring, don't use it then. You will have to keep your original 93 Supercharged PCM.

The transmissions don't have "TRAC" options. That'* all built into the ABS system. Fix the ABS issue and your ABS and TRAC lights should go away.

Are you sure its running rich? Only thing I can think of that would cause that is if your running a PCM not programmed for supercharged engines. Did the injectors appear to be the same as the ones on your old engine?
Mike is offline   Reply With Quote
Old 11-16-2012, 02:52 PM   #20
Senior Member
Posts like a 4 Banger
Thread Starter
 
Mr Fix It's Avatar
 
Join Date: Jul 2009
Location: Nebraska
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mr Fix It is on a distinguished road
Default

Im running the 93 pcm and the 93 supercharger/fuel rail on the 94 block. I can get it to stay running as of now with the MAF plugged in just runs choppy i found a vacuum leak (egr tube that goes into supercharger behind the throttlebody there, thinking about plugging that whole and just not having egr but leave the connector plugged in ) and will fix it when i get out of class, but it just reeks of unburned fuel out the exhaust it burns my eyes when im near the car and its running. hopefuly when i get the vacuum leak taken care of it will run better. otherwise it sounds good no knocks or pings etc. Ill look into the abs system as well.Thanks!.
Mr Fix It is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My 94 Park Ave. Ultra rotyp Buick 2 11-18-2006 07:01 PM
My 94 Park Ave. Ultra rotyp Your Ride: GM Pictures & Videos 14 09-18-2006 03:08 PM
1994 Park Ave. Ultra rotyp 1992-1999 1 09-13-2006 12:00 PM
95' Park Ave Ultra-anyone w/racing experience? SUPERVAN Introductions for new members 9 03-03-2005 09:46 PM
96 Park Ave Ultra alignment specs karfreek Buick 0 08-16-2004 09:55 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:51 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.