PCM responsible For Intermittent Electrical Probs? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-09-2012, 11:54 PM   #1
Senior Member
True Car Nut
Thread Starter
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,579
Thanked 335 Times in 298 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default PCM responsible For Intermittent Electrical Probs?

Man What'* up with this 97 PA with 85 k miles?
Hoping someone here can point me in the right direction since I have no FSM here. Intermittent Electrical Problems & stored codes:

Today start the car. No power windows, no power mirrors, no locks, no nothing at driver'* door. Was warm out too, good thing the AC was cold and working.
Got to destination (lunch) shut off car. Used remote to test locks ya it works.
Come back out re- start car and the windows and all door stuff works again.
So far one time glitch.

Sometime the AC/ Clutch fails to operate. Low voltage or none at all. Replaced AC fuse/ Relay.....so far so good. Code P1654 AC Relay control -improper voltage was set. Going to have to clear and see what happens.

Transmission Code P1811 sometimes when hot, hard shifts felt in stop and go traffic. Re Start car and some times it goes away.

While in key in ACC mode stereo on, sometimes the interior lights come on and stay on for 20 seconds..go out then come back on around 5 min then repeat...go figure.

Windshield wipers ( has rain sensing tech) when on slow delay, often go to turn them off and the wipers do not go the the bottom of shield and then down like they are suppose to, they stop some where in middle of shield.
If you use the washer and then turn them off they return to bottom as normal, or if you re-start car then often are ok.

P1604 Loss of IPC Serial Data (no clue on that)
P1641 No set MIL Light.

Anyways does this sound like a bad module or computer, PCM or WTF is causing all these glitches??
By the way I have installed a new Odyssey AGM battery.
Ideas Appreciated. THX!
Soft Ride is offline   Reply With Quote
Old 04-10-2012, 07:53 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

you have the other thread for the majority of these things, the only thing i would add is check out the two ground buss one each driver front door sill under carpet and passenger. to loose your serial data is like a computer it maybe the serial data wire is intermittent or it may be intermittently loosing power or ground and not have anything to do with the data line itself.

https://www.gmforum.com/showthread.php?t=278980
jwfirebird is offline   Reply With Quote
Old 04-10-2012, 08:25 AM   #3
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Your pcm controls almost none of that. You likely have the ground issues mentioned already or your battery cables are loose/corroded.
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
GM claims not responsible for Impala problems from before bankruptcy niceguy Chevrolet 6 08-31-2011 11:41 PM
weird cabin electrical probs on a 2000 LeSabre sonoma_zr2 Everything Electrical & Electronic 1 01-05-2007 11:32 PM
intermittent electrical problem, ideas? TDS-94SSEi Everything Electrical & Electronic 22 06-21-2006 01:57 PM
PCM Electrical readings jkinney Everything Electrical & Electronic 3 02-04-2004 07:31 PM
idle probs and starter probs(kinda long) 92ssei 1992-1999 6 04-02-2003 04:19 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:14 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.