Dial cluster troubles with mom's '97 LeSabre Limited. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-21-2007, 02:09 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2007
Location: Wisconsin
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
Andx0r is on a distinguished road
Default Dial cluster troubles with mom'* '97 LeSabre Limited.

The tachometer and fuel guage, specifically.

The tach works sporadically. Sometimes works, sometimes just sits there dead. Totally random.

The fuel guage is generally pegged at F. Occasionally it'll drop to 3/4 or half a tank at random, but usually stays at full no matter what the actual fuel level is. We've just been filling the tank when the trip odo hits 300 miles.

I'm not really sure what to make of this. Any thoughts? Everything else works just fine. All I've really done so far is check the fuses.
Andx0r is offline   Reply With Quote
Old 04-21-2007, 11:10 PM   #2
Senior Member
True Car Nut
 
Join Date: Dec 2003
Location: Corn Fields, IN
Posts: 2,766
Thanks: 0
Thanked 0 Times in 0 Posts
John Deere Boy is on a distinguished road
Default

Well there are two possiblities i can come up with. One, it could be that contacts on the back of the cluster need cleaned. There is a techinfo article on cleaning bonneville clusters. Or two, the contacts on the back of the cluster need cleaned, and coincidentally the fuel tank sending unit is also bad and needs replaced.
John Deere Boy is offline   Reply With Quote
Old 04-21-2007, 11:51 PM   #3
Senior Member
Posts like a Turbo
 
Join Date: Mar 2007
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
ptrfair is on a distinguished road
Default

ok so heres more of an "your're not the only one" answer...

my pop'* 97 Limited had this issue. the car had 50,000 miles..

We went to the dealer and they gave us a brand new cluster. Our gas gauge was never accurate, infact before GM replaced the whole unit, their service guys reversed the connection for the gas, and it was always on E. This was what they did to see if the connections just needed to be cleaned, however sometimes odometers cant be fixed and need replacement. Believe me i remember those days, not fun.

Does your speed needle sometimes not work correctly? How many miles are on the car? I would also check out the Fuel tank sending unit. Im no expert on that, but it makes logical sense.
Goodluck
pete

FYI - my sister inherited the car and to this day the cars run perfect besides that issue.
ptrfair is offline   Reply With Quote
Old 04-23-2007, 09:50 PM   #4
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2007
Location: Wisconsin
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
Andx0r is on a distinguished road
Default

The car'* got 160,000 miles and everything else in the dash works perfectly. It'* just the gas and tach dials.
Andx0r is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HVAC problems with my 1997 Buick LeSabre Limited Andx0r Buick 2 02-28-2008 09:02 PM
mom & hailey, mom & kim, mom & kim & mom harofreak00 Lounge 6 04-09-2007 03:40 PM
My 1997 Buick LeSabre Limited LeSabreUltra Your Ride: GM Pictures & Videos 22 04-02-2007 12:02 PM
2004 LeSabre Limited; WOOT! I did it again! (now with PICS) agrazela Introductions for new members 6 01-19-2007 10:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.