99 Regal LS "Service engine soon" light - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-02-2007, 11:32 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2005
Location: Pawnee, OK
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
atryko is on a distinguished road
Default 99 Regal LS "Service engine soon" light

Have just had this car for a week. It has run wonderfully for the most part until this afternoon. (I intend to do the UIM & LIM gasket updates as a preventative measure in the near future) The car had a bit of a sputter for about 5-10 seconds and the SES light came on. Then the car seemed to run just fine, but of course the light was still on. I had to drive it this way for several miles...but, like I said before it drove just fine after that 5-10 second sputtering. Another strange thing happened after I restarted the car, perhaps unrelated, but the gas gauge creeped all the way to full...then slowly dropped back to where it was supposed to be. I don't know...does this sound like anything you guys have dealt with before?
atryko is offline   Reply With Quote
Old 06-03-2007, 02:54 AM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Go get a scan and let us know what the codes are. We can't even begin to guess what it might be.
willwren is offline   Reply With Quote
Old 06-26-2007, 10:06 AM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2005
Location: Pawnee, OK
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
atryko is on a distinguished road
Default

One last stupid question on this topic: What size spark plug socket am I going to need to pull my plugs? I've never changed plugs and wires before...is there anything I need to be aware of that isn't blantantly obvious?
atryko is offline   Reply With Quote
Old 06-26-2007, 10:07 AM   #4
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

You'll need the smaller socket. IIRC 5/8"

On the back plugs. You might be able to undo the dog bone mounts and use a pry bar in the lift bracket to pull the engine forward and put a bolt back into the dogbone on an closer position.
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Service Engine Soon and Traction Control. 2000 Regal LS Grahamski Buick 5 12-07-2011 12:46 PM
Flashing "Service Engine Soon Light" when under hard acceleration Hesk000 2000-2005 18 10-27-2009 02:46 PM
"Service Engine Soon" Light Leonardo 2000-2005 10 10-07-2009 09:34 AM
"Service engine soon" TheMPG 1987-1991 9 04-17-2005 12:20 AM
question on resetting "SERVICE ENGINE SOON" Nebssei 2000-2005 3 09-03-2004 10:24 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:19 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.