2000 Regal Wont Stay Running! 3.8 SC - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-02-2012, 07:03 AM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Johnnyg is on a distinguished road
Default 2000 Regal Wont Stay Running! 3.8 SC

The problem started the day I was driving during a heavy rain storm. Not sure if it was related or just a coincidence.
The engine just stopped running. I was able to restart but it will only run for a few seconds and stop. The following items have been changed or verified ok with good components.

Fuel pump - Changed
MAF sensor - Changed
Crank Shaft positioning sensor - Changed
Fuel pump relays Ė verified ok

With a fuel pressure gauge attached you can see the pressure go up to approximately 50 psi when the key is first turned on. As soon as you start the car the pressure drops and stalls.
There is two ways I can keep the engine running.
1. If I hold the accelerator pedal full throttle the pump runs building pressure and the engine stays running. The psi drops the moment I start to decelerate below the rev limiter.
2. I can make the car run normal by jumping across the normally closed contact (forcing it closed) on the fuel pump relay (spd cont), I think ití* labeled # 19.
I donít know where to go from here. Donít want to keep adding unnecessary parts.
Any advice would be appreciated.
2000 Buick Regal GS
3.8 SC
Johnnyg is offline   Reply With Quote
Old 10-02-2012, 08:53 AM   #2
Retired Administrator

True Car Nut
 
GunsOfNavarone's Avatar
 
Join Date: Apr 2009
Location: Williamsport, PA
Posts: 2,856
Thanked 167 Times in 129 Posts
GunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud of
Default

Not heard of this problem on vehicles with the 3.8L, but on GM'* with the 4.3L, the fuel pump ground wire corrodes and causes the fuel pump to intermittently stop.
GunsOfNavarone is offline   Reply With Quote
Old 10-02-2012, 11:00 AM   #3
-- SITE DONATOR --
True Car Nut
 
ymmot04's Avatar
 
Join Date: May 2009
Posts: 4,638
Thanked 5 Times in 4 Posts
ymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of lightymmot04 is a glorious beacon of light
Default

I didn't see mention of the Fuel Filter being changed?
ymmot04 is offline   Reply With Quote
Old 10-02-2012, 12:07 PM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

if he can get it to run normaly by bypassing the relay everything from there back is good
i dont have time to go through the drawings now but either the pcm isnt calling for it to run or you have an open from the pcm to the relay
jwfirebird is offline   Reply With Quote
Old 10-02-2012, 12:33 PM   #5
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Pcm is calling for fuel at first turn on of the key. Otherwise he would not get the initial pump prime to 50psi. He needs to verify via a test light on the pump wires to see if its being shutoff or if its somewhere else.
Mike is online now   Reply With Quote
Old 10-02-2012, 03:28 PM   #6
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

thats right. it must be good so what what would cause the pcm to prime and not run after?
jwfirebird is offline   Reply With Quote
Old 10-02-2012, 03:36 PM   #7
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

this is the one with the funky resistor and if that opened i think it may do something like that

Attached Thumbnails
2000 Regal Wont Stay Running! 3.8 SC-2000regalfp.gif  
jwfirebird is offline   Reply With Quote
Old 10-02-2012, 03:41 PM   #8
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

jwfirebird is offline   Reply With Quote
Old 10-02-2012, 05:37 PM   #9
Junior Member
Thread Starter
 
Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Johnnyg is on a distinguished road
Default

Jwfirebird, I think you on to something with this resistor. Called one local Gm dealer and they didn't know what I was talking about. Auto parts store didn't have it listed either.. On my model I'm told its hidden behind the washer reservoir. I'll track it down and check it out. Thanks
Johnnyg is offline   Reply With Quote
Old 10-05-2012, 06:36 AM   #10
Junior Member
Thread Starter
 
Join Date: Oct 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Johnnyg is on a distinguished road
Default

As turns out it was the resistor. Found the ceramic had cracked in half. The new kit from GM has you relocate on the firewall. Thanks for all your help. Today I'm going to tackle the heater / AC display which hasn't worked in several years.
Johnnyg is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
95 regal courtesy light stay on buicker Buick 7 04-09-2011 12:26 AM
wont stay running bwelsh 1992-1999 3 12-11-2009 07:18 PM
1996 Bonneville SSEI Wont stay running/Fuel issue? gmanjeep 1992-1999 9 08-07-2009 10:55 PM
2000 Bonnie won't stay running ceg 2000-2005 7 07-29-2009 08:08 PM
Traction control wont stay on sam5828 2000-2005 7 11-26-2005 10:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:28 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.