GXP instrument cluster - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Bonneville GXP/ Northstar Powered Cars Discuss your Bonneville GXP and/or any other Northstar powered Olds or Cadillac... Including the 3.5L Twin Cam V6 (Short Star ) 4.0L and 4.6L Northstar V8's. Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-22-2006, 10:00 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
gxp007 is on a distinguished road
Default GXP instrument cluster

Has anyone had repeated problems with their instrument cluster in their GXP. I had it in the shop 3 times but of course they could not verify the problem. So I took it in when it was doing it and the technician tried to tell me there was nothing wrong........I say B.*. but they finally decided to order a instrument cluster for it. The problems I am having is this, coolant gauge works when it wants to and stops where it feels like , one day no coolant gauge, no gas guage, and the tach was off by plus 1000 rpms and then it went off the scale. Came out later that day everything fine again. It seems to screw up when it is over 80 outside, I believe the processor inside the cluster is screwed up. Hopefully when the new cluster is installed there will be no more problems.
gxp007 is offline   Reply With Quote
Old 08-23-2006, 04:08 AM   #2
Administratus Emeritus
Certified Car Nut
 
GXP Venom's Avatar
 
Join Date: Jan 2006
Location: Purgatory, Pennsylvania
Posts: 16,538
Thanked 7 Times in 4 Posts
GXP Venom is on a distinguished road
Default

Sorry to hear this GXP 007 and welcome to the Club. This is a new one and I hope it gets worked out and please keep us informed. The electrical system as a whole is engineered to close for comfort wire gauge wise and the is already a TSB for the fog lights burning out and the lower harness frying. As well the battery in the rear doesnt help. Neither does the shoddy ground to body under the back seat which I redid on mine as the mods went in.When the fog lamp issue became apparent I said there will most likely be other electrical issues and am very interested in what you find out.
GXP Venom is offline   Reply With Quote
Old 08-23-2006, 04:15 PM   #3
Senior Member
True Car Nut
 
Join Date: Feb 2006
Location: Delaware & Long Island NY
Posts: 3,239
Thanks: 0
Thanked 0 Times in 0 Posts
Shadow is on a distinguished road
Default

Quote:
Originally Posted by GXP Venom
Sorry to hear this GXP 007 and welcome to the Club. This is a new one and I hope it gets worked out and please keep us informed. The electrical system as a whole is engineered to close for comfort wire gauge wise and the is already a TSB for the fog lights burning out and the lower harness frying. As well the battery in the rear doesnt help. Neither does the shoddy ground to body under the back seat which I redid on mine as the mods went in.When the fog lamp issue became apparent I said there will most likely be other electrical issues and am very interested in what you find out.

Hey venom think that the bonnevilles wirirng is tough? My BMW uses fiber optic wiring throughout. I cant even installed an aftermarket anything. I seriously wonder what the build-date is of these problem GXPs. I know yours and mine had the same cosmetic problems like body molding and sunroof visor but none of these other problems. There must have been a bad batch in the end I guess?
Shadow is offline   Reply With Quote
Old 08-23-2006, 11:50 PM   #4
Junior Member
 
Join Date: Oct 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Johnny M. is on a distinguished road
Default Re: GXP instrument cluster

First time to post in Club. 2005 GXP and the Low Coolant light goes on at start. Is this a start of a bad trend? Loving the car though.
Johnny M. is offline   Reply With Quote
Old 08-23-2006, 11:52 PM   #5
Administratus Emeritus
Certified Car Nut
 
GXP Venom's Avatar
 
Join Date: Jan 2006
Location: Purgatory, Pennsylvania
Posts: 16,538
Thanked 7 Times in 4 Posts
GXP Venom is on a distinguished road
Default

It'* a BMW whatdayaneed w/ aftermarket !...... I think there is little difference between the 04'* and 05'* Shadow. We both have/had new ones. Mine still only has 4500 miles on it. And My fog lamp harness was replaced before it became a problem. When a wire in a harness gets so hot to burn out the fog lamp power feed, what do you think it does to the rest of the wires in that harness..... Not good. As well when you put out 50,000 vehicles, a few are going to have their own distinct problems. I replaced the cheap little plated OEM ground lug with a heavier cooper one. and actually sanded the paint down to metal and dabbed No-Ox on it, Because of my air compressors, switches and selenoids, audio, lighting, etc. As well they were all grounded to the body. Not that Pontiac is the only one by far. I have looked at alot of various new cars and most are electrically engineered to a fine line. Too fine I think. My biggest worry now is the altenator, but I'm not going to take out a new one till it smokes. LOL

007 what year GXP do you have and how many miles are on it
GXP Venom is offline   Reply With Quote
Old 08-24-2006, 12:09 AM   #6
Administratus Emeritus
Certified Car Nut
 
GXP Venom's Avatar
 
Join Date: Jan 2006
Location: Purgatory, Pennsylvania
Posts: 16,538
Thanked 7 Times in 4 Posts
GXP Venom is on a distinguished road
Default Re: GXP instrument cluster

Quote:
Originally Posted by Johnny M.
First time to post in Club. 2005 GXP and the Low Coolant light goes on at start. Is this a start of a bad trend? Loving the car though.
Well this seems to be the week for new GXP owners. Wekcome Johny, and please take the time to introduce yourself in the forum section. And thats a whole new one for the Club. Love mine as well but it would seem there is alot of very different problems going on with these electrical systems..Johny, we are asked to post a new thread when we have a new problem, but yours is very similar to 007'*. Better get it back to the dealer, I assume you checked the coolant level. My coolant lite has never come on at startup or otherwise so if is definately not right. Plase keep us informed what Mr. Goodwrench has to say...... Your going to see him a couple times it seems before the quirks are all worked out. Pontiac may have lost money on these GXP'* but the Dealers are making a fortune on them.
GXP Venom is offline   Reply With Quote
Old 08-24-2006, 12:26 AM   #7
Senior Member
Posts like a Supercharger
 
Join Date: May 2003
Location: Metro Detroit
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
BlackIce is on a distinguished road
Default

Had the Low Coolant light on in my car until the car warmed up to operating temp. Dealer diagnossed it as a faulty radiator cap and replaced it, have not seen the light since.
BlackIce is offline   Reply With Quote
Old 08-24-2006, 10:37 AM   #8
Junior Member
 
Join Date: Mar 2003
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
vital49 is on a distinguished road
Default

Johnny M. - please start a new thread with your specific issue. Thanks.
vital49 is offline   Reply With Quote
Old 08-24-2006, 02:06 PM   #9
Senior Member
True Car Nut
 
Join Date: Feb 2006
Location: Delaware & Long Island NY
Posts: 3,239
Thanks: 0
Thanked 0 Times in 0 Posts
Shadow is on a distinguished road
Default Re: GXP instrument cluster

Quote:
Originally Posted by Johnny M.
First time to post in Club. 2005 GXP and the Low Coolant light goes on at start. Is this a start of a bad trend? Loving the car though.
My car did the same thing. It was a 2005 GXP. Bring it to the dealer they replaced the sensor in mine. They replaced the entire overflow container and seized cap. if you do a search it should be on here as I posted a topic about it many months ago.
Shadow is offline   Reply With Quote
Old 09-05-2006, 11:01 PM   #10
Junior Member
Thread Starter
 
Join Date: Aug 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
gxp007 is on a distinguished road
Default gxp instrument cluster replaced

Ok so today I got my instrument cluster replaced my mileage has gone back about 3200 miles, which helps my warrenty. As soon as I stepped into the car and drove out of the dealership I noticed that the radio display was half dim and bright, then I noticed a high pitched squeel and creeking noise when turning left only........ What else could I say but "WTF" IS GOING ON HERE. I was so pissed about this, I just felt it is better that I find another dealer to go to before I blow my top again. One good thing though the avg fuel milage is finally reading right at 20.5 mpg. It was always about 1 to 2 mpg off and I had it checked before and they said nothing was wrong.
gxp007 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Service info: 1992 SSEI Instrument Cluster TelePlayer 1992-1999 1 10-02-2008 02:07 PM
GXP Instrument Cluster Issues *B2* Everything Electrical & Electronic 3 09-09-2007 03:14 PM
Looking for an Instrument cluster for an 88 SSE BonnevilleSSEGuy General GM Chat 1 01-01-2004 03:35 PM
System Monitor in instrument cluster givemebreak Everything Electrical & Electronic 16 11-10-2003 09:01 PM
another instrument cluster question egladman 1987-1991 4 07-03-2003 12:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:20 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.