DIC crapped out - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Bonneville GXP/ Northstar Powered Cars Discuss your Bonneville GXP and/or any other Northstar powered Olds or Cadillac... Including the 3.5L Twin Cam V6 (Short Star ) 4.0L and 4.6L Northstar V8's. Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-25-2006, 10:05 AM   #11
Administratus Emeritus
Certified Car Nut
 
GXP Venom's Avatar
 
Join Date: Jan 2006
Location: Purgatory, Pennsylvania
Posts: 16,538
Thanked 7 Times in 4 Posts
GXP Venom is on a distinguished road
Default

I had two panels give me trouble and when the custom shop did my paint they put a black urethane adhesive made for body kits on to hold them pernamently. A automotive paint store there should carry it. It comes in tubes to fit caulking guns. Hope they get your DIC up and running proper.
GXP Venom is offline   Reply With Quote
Old 07-27-2006, 09:48 PM   #12
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2006
Location: Honolulu, HI
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
marauder307 is on a distinguished road
Default

Still no word from the dealer on what the tech support line said...I went ahead and called
GM Customer Assistance today and pitched a bitch. 37k+ spent for this car and a 10$ button/switch panel gives up the ghost after only 3 1/2 months. Unsat. The Cust. Assist line has assigned me a case number; we'll see if we can finally get some movement on this.
marauder307 is offline   Reply With Quote
Old 07-28-2006, 01:27 AM   #13
Senior Member
Posts like a 4 Banger
 
Join Date: Jul 2006
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
2.3 Turbocoupe is on a distinguished road
Default

Marauder, I'm interested in hearing what the fix is, because I just bought an 05 GXP, and apparently it has the same problem. Even when I hold down the Reset button for 5+ seconds as per the manual, average fuel economy and total gallons used does not reset.

Total gallons used is at 65, so apparently the previous owner was recently able to reset this.
2.3 Turbocoupe is offline   Reply With Quote
Old 07-28-2006, 03:29 PM   #14
Administratus Emeritus
Certified Car Nut
 
GXP Venom's Avatar
 
Join Date: Jan 2006
Location: Purgatory, Pennsylvania
Posts: 16,538
Thanked 7 Times in 4 Posts
GXP Venom is on a distinguished road
Default

Ut oh another one.... Hope they get it figured out and you guys get back to us. Untill them, Venom is reseting with a very lite finger.
GXP Venom is offline   Reply With Quote
Old 08-03-2006, 12:10 PM   #15
Senior Member
Posts like a 4 Banger
 
Join Date: Jul 2006
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
2.3 Turbocoupe is on a distinguished road
Default

Well, my DIC reset is now working…sort of…I’ll explain

Yesterday I was messing with the DIC, and realized that the reset button is used to change the personalization settings. And I noticed that in that mode, the reset button was working fine. So at that point I realized that there was not a problem with the button. Marauder, you might want to check that as well.

Then immediately afterward I tried again to reset the total gallons used. Bingo, it reset fine on the first try (and I had previously tried unsuccessfully before probably 20 times).

Then I tried resetting the average MPG. No luck. I went back through the personalization settings again, then tried another reset, but still not working. Finally, in frustration I tried pushing the button several times in rapid sucession, and….the damn thing reset! Weird!

This morning, I was able to reset the gallons used just fine, but again the average MPG would not reset. And pushing it several times in rapid succession worked again.

So I guess for now I am good, if not a little baffled.
2.3 Turbocoupe is offline   Reply With Quote
Old 08-04-2006, 01:13 AM   #16
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2006
Location: Honolulu, HI
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
marauder307 is on a distinguished road
Default

Tried all of the above...no such luck. The big difference here is that I've already had Mr. Goodwretch look at mine once...I suspect that probe with the voltmeter probably did more damage than good. My computer still functions, but no reset available on any of the settings now---if my compass loses calibration, I'm SOL. Same for the personalization functions.

To make bad matters worse...I discovered one of the dash screws (up inside the "eyebrow" over the guages) has been broken; again, probably by the kid at Goodwretch. Multiple phone calls to the service writer and the service manager at the dealership have gotten no response, and GM Customer Assistance can't even get the dealer to call 'em back.

I'm down now to homegrown remedies and trying another dealer. Can anybody get me a pic of the back of that switch panel and show me the ground wire and the harness? I'm gonna try to pull the cover this weekend and simply try manipulating the wires to see if I can get a response...no voltmeter probing.
marauder307 is offline   Reply With Quote
Old 08-04-2006, 12:27 PM   #17
Senior Member
True Car Nut
 
Join Date: Feb 2006
Location: Delaware & Long Island NY
Posts: 3,239
Thanks: 0
Thanked 0 Times in 0 Posts
Shadow is on a distinguished road
Default Re: The story thus far...

Quote:
Originally Posted by marauder307
Oil change done, no problem.

The passenger side rear door panel is a no-go; they're telling me it'* a $700 replacement job for the entire panel. Looks like the trim shop that did the work broke the retaining clips at the top of the panel, so Goodwrench won't do the job under warranty.
...
Well the dealer will look for any reason not to honor the warranty if its any sory of hard job. My emergency..couch parking brake would not release and my cars had to be towed to the dealer twice. Finally they fixed it by replacing the entire assembly but first claimed that the aftermarket sub I had in the trunk caused the problem cause the power wire got jammed with the parking brake assembly. I cried foul and they fixed it under warranty.
Shadow is offline   Reply With Quote
Old 08-04-2006, 05:03 PM   #18
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2006
Location: Honolulu, HI
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
marauder307 is on a distinguished road
Default Finally....maybe....

Got a panicky phone call from the dealer today; turned out to be a 3-way call between the general manager, the GM Customer Assistance rep, and me. I won't bore you with the verbatim detail of what the general manager said, but he was rather apologetic...even promised to "counsel the service writer", who apparently did not write the invoice up correctly leaving the gm thinking that the HUD was the malfunctioning part rather than the DIC...bottom line of all this is that---against my better judgement---I'm taking it back to them Thursday of next week and they'll try to fix it again.

IMO, I don't think the service writer screwed up; I think she did it on purpose. This next trip will be service call #2 for this problem. The HI state lemon laws---which are pretty much in line with everybody else---state that if the vehicle'* broken for over 30 days and has come in 3 times for the same problem, the dealer'* gotta take it back. Because the service writer muffed the write-up, this will only be---on the OFFICIAL record, now---the first time this car'* come in for this problem. So what the SW did was buy the dealer some extra time. The car will have been broken for over 30 days...but it won't have hit the magic "3-strikes" yet.

Devious, aren't they? After this fix I'm changin' dealers...
marauder307 is offline   Reply With Quote
Old 08-06-2006, 02:17 PM   #19
Senior Member
Posts like a 4 Banger
 
Join Date: Jul 2006
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
2.3 Turbocoupe is on a distinguished road
Default

Quick update. My DIC reset has been working fine for several days now.
2.3 Turbocoupe is offline   Reply With Quote
Old 08-07-2006, 09:30 PM   #20
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2006
Location: Honolulu, HI
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
marauder307 is on a distinguished road
Default

Quote:
Originally Posted by 2.3 Turbocoupe
Quick update. My DIC reset has been working fine for several days now.
OK...did you do anything special to it? Or did it simply clear itself up?

Going in Thursday for this...I don't really know what to tell 'em...
marauder307 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rear passenger side suspension is lower , crapped a tire... mike_peperni 2000-2005 3 04-11-2006 02:10 AM
Bonneville crapped out on me tonite. egladman 1992-1999 14 03-16-2006 08:40 AM
DIC reporting Turn Signal Light Out Merlin 91/97 1987-1991 4 06-02-2003 02:14 PM
DIC AND COMPASS PROBLEMS shortstuf212559 1992-1999 7 02-11-2003 02:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:43 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.