Where did the Time go? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 03-09-2007, 08:55 AM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: Oct 2005
Location: Central Florida
Posts: 7,030
Thanks: 0
Thanked 0 Times in 0 Posts
lash is on a distinguished road
Default Where did the Time go?

I think it'* on vacation...hope it comes back soon...

No display anymore on the HU. No time, no radio station, no nuttin'. Tape and radio still work great with no change.

OK, so here'* the scoop. Last Fall, Don and I popped in a stock tape player w/equalizer HU in my SE to replace the poorly working original tape player HU. In addition to losing the signal quality in the right channel, the old HU display had begun to fail.

Now the Display on this one is gone completely. My wife, Liz, drives the car daily and told me last night that the display had begun to go screwy a couple months ago, on a sometimes basis. It would come up all chinese characters when first powered up, the eventually display time and channels correctly. It started getting worse and worse and as of yesterday, quite displaying anything at all. For some reason, she didn't tell me about it until last night...

Like said, the rest of the unit works fine.

Among others I have, there are these questions:

1. Is there a specific pinout or wire that controls power to just the display?

2. If so, which one is it and how do I fix it? Understand that I have never paid much attention to audio, so keep it simple for stupid, if you please.

3. Has anyone else ever experienced this failure mode?
lash is offline   Reply With Quote
Old 03-09-2007, 09:04 AM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

The light bulb doesn't work?

You can replace the light bulb. (being the king of search..look for Travis and Andrew for the part numbers)
BillBoost37 is offline   Reply With Quote
Old 03-09-2007, 09:12 AM   #3
Senior Member
True Car Nut
Thread Starter
 
Join Date: Oct 2005
Location: Central Florida
Posts: 7,030
Thanks: 0
Thanked 0 Times in 0 Posts
lash is on a distinguished road
Default

Quote:
Originally Posted by BillBoost37
The light bulb doesn't work?

You can replace the light bulb. (being the king of search..look for Travis and Andrew for the part numbers)
I could be wrong, but I din't think it'* a light bulb that I'm talking about. I mean that the digital readout started to go crazy on start up. Initialy creating weird characters , then setling in to read the correct time and or station. That should be some sort of LEDs or something, NO?

This is not the backlighting.

Edit:
It isn't the backlight I'm talking about. It'* the LCD. I think it has to do with power supply. At least that'* what the symptoms seemed like.

Here'* a pic of the HU I have:

Name:  Bville052306007.jpg
Views: 0
Size:  32.0 KB
lash is offline   Reply With Quote
Old 03-09-2007, 11:39 AM   #4
Senior Member
True Car Nut
Thread Starter
 
Join Date: Oct 2005
Location: Central Florida
Posts: 7,030
Thanks: 0
Thanked 0 Times in 0 Posts
lash is on a distinguished road
Default

Just wanted to bump this while all you electronic geeks are here. My original posts were before anybody was on.

Can ya help me?
lash is offline   Reply With Quote
Old 03-09-2007, 02:17 PM   #5
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

That thing is not entering failure mode is it...

Do you still have the old unit? Wonder if the parts are swapable

And on a side Note mine does alien from time to time as well... Been doing it for the last 4 years

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 03-09-2007, 02:30 PM   #6
Senior Member
True Car Nut
Thread Starter
 
Join Date: Oct 2005
Location: Central Florida
Posts: 7,030
Thanks: 0
Thanked 0 Times in 0 Posts
lash is on a distinguished road
Default

I don't believe that the HU itself if entering failure mode, only because there'* been no reduction in the music quality, functions, volume, etc. It seems to be only affecting the LED display.

I know that there are a few folks on here that have dissected the HUs and know their functioning and pin-outs.

I had sort of hoped that it was maybe an intermittent, going on permanent, short or something to just one supply wire or or circuit. It'* probably wishful thinking, but...
lash is offline   Reply With Quote
Old 03-09-2007, 02:42 PM   #7
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

Ok.. Later when you get home...

Turn the Ignition on, make sure you have tunes playing...

Take a flashlight and point it straight at the display... If you see any hint of numbers or time or Alien Scratch( Wanna Be numbers ) the the LCD is working but the bulb is out...

Is the LCD dark, or does it have a Reddish Glow at all?

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 03-09-2007, 02:45 PM   #8
Senior Member
True Car Nut
Thread Starter
 
Join Date: Oct 2005
Location: Central Florida
Posts: 7,030
Thanks: 0
Thanked 0 Times in 0 Posts
lash is on a distinguished road
Default

K.

I'll check and get back to ya.
lash is offline   Reply With Quote
Old 03-10-2007, 08:51 AM   #9
Junior Member
 
Join Date: Mar 2003
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
vital49 is on a distinguished road
Default

I'm 99% sure that'* my old HU that I sold to Don for ~$10 a couple years ago!

I sold it so cheap because the display would get jumbled up in my 99 (and because I wanted a CD player).
vital49 is offline   Reply With Quote
Old 03-10-2007, 09:24 AM   #10
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Mike, i played this game with the GF'* GP GT. she had a 2 band CD and we swapped in a 7band CD. put it in and NO display. I took the bulb from behind the display of the known good one and swapped it in to the 7 Band. Now the 7 band works and you can always see the display
1993 SLE is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What did I wash this time!? captainmiller Your Ride: GM Pictures & Videos 5 04-24-2007 07:55 PM
How did you hear about BC and why did you join? BLACK94SSEi Lounge 43 05-14-2006 01:00 AM
BC room down time. what did you do? Gumball Lounge 22 12-31-2005 02:27 PM
something i should of did along time ago GAMEOVER 1992-1999 8 07-02-2005 10:39 PM
i really did it this time Red Baron 1992-1999 5 06-11-2003 10:43 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.