weird idle - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-24-2011, 01:26 PM   #11
Senior Member
Posts like a Northstar
Thread Starter
 
Nobotada84's Avatar
 
Join Date: Apr 2009
Location: Indianapolis, Indiana
Posts: 699
Thanks: 0
Thanked 0 Times in 0 Posts
Nobotada84 is on a distinguished road
Default

Ok so I spoke to soon. On my way home from work my old friend "SES" showed up again. I replaced both the IAC and the PCV,(had a credit on my rewards card)and the ses light is still on and the car still shakes at idle.I'm stumped.
Nobotada84 is offline   Reply With Quote
Old 03-24-2011, 01:30 PM   #12
Senior Member
Posts like a Corvette
 
Nighthwk12's Avatar
 
Join Date: Feb 2009
Location: Jersey Shore
Posts: 1,511
Thanks: 0
Thanked 0 Times in 0 Posts
Nighthwk12 is on a distinguished road
Default

Still putting money on the filter. For the idle no way to check it but it'* only $15 for a new filter.
Nighthwk12 is offline   Reply With Quote
Old 03-24-2011, 07:07 PM   #13
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

If it rattles it should be good, but no harm other then the cost in replacing it.
Danthurs is offline   Reply With Quote
Old 03-27-2011, 05:29 PM   #14
Senior Member
Posts like a Northstar
Thread Starter
 
Nobotada84's Avatar
 
Join Date: Apr 2009
Location: Indianapolis, Indiana
Posts: 699
Thanks: 0
Thanked 0 Times in 0 Posts
Nobotada84 is on a distinguished road
Default

Took the car in to get smoke tested on friday. Everything checked out. No leaks. Also had fuel pressure checked. It was at 42 psi. I was told 45-55 was normal but 42 was acceptable. Hooked car up to diagnostic machine, got no response from MAP sensor. Even unplugged it and nothin happened. I mean shouldn't the car have died? Anyways replaced the MAP and what do u kno, still runin lean still shakin at idle. Diagnostic said pcm keeps tellin engine to run lean but then it richens back up when I get on throttle. Possible bad 02. The battle continues....
Nobotada84 is offline   Reply With Quote
Old 03-30-2011, 11:29 AM   #15
Senior Member
Posts like a Northstar
Thread Starter
 
Nobotada84's Avatar
 
Join Date: Apr 2009
Location: Indianapolis, Indiana
Posts: 699
Thanks: 0
Thanked 0 Times in 0 Posts
Nobotada84 is on a distinguished road
Default

Ok guys update time. Turned out my engine was not likin the 42 psi that my fuel pump was runnin. installed a new pump and fuel pressure is back well within the suggested psi. now my oh crap moment. discored a leak at the base of my supercharger. the new pump although it made the car idle a whole lot smoother didnt completely solve my p0171 issue. so i was randomly spraying carb cleaner, hit the base of the SC right inbetween 2 of the injectors and i heard the idle change. looked a little closer and the zzp gasket that was on there has a bit of overhang, it was enough to keep it sealed during the smoke test but twhen i pulled it down a little and sprayed, definite leak. so needless to say got a sc gasket change comin up here soon. HOPEFULLY this will resolve the issue. im goin on a full month here dealin with this thing. I'll post pics of the engine when im done, thing looks brand new with all the new parts she'* gotten tryin to fix this thing. keep u posted.
Nobotada84 is offline   Reply With Quote
Old 03-30-2011, 12:39 PM   #16
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

This is why I make my own supercharger gaskets.
Danthurs is offline   Reply With Quote
Old 03-31-2011, 04:26 AM   #17
Senior Member
Posts like a Northstar
Thread Starter
 
Nobotada84's Avatar
 
Join Date: Apr 2009
Location: Indianapolis, Indiana
Posts: 699
Thanks: 0
Thanked 0 Times in 0 Posts
Nobotada84 is on a distinguished road
Default

Oh yeah i forgot u were doin that dan. What are you using to do that?
Nobotada84 is offline   Reply With Quote
Old 03-31-2011, 10:14 PM   #18
Administratus Emeritus
Certified Car Nut
 
GXP Venom's Avatar
 
Join Date: Jan 2006
Location: Purgatory, Pennsylvania
Posts: 16,538
Thanked 7 Times in 4 Posts
GXP Venom is on a distinguished road
Default

Moved to Mechanical/Bonneville/2000-2005 for better visibilty and search engine indexing.
GXP Venom is offline   Reply With Quote
Old 04-08-2011, 07:51 PM   #19
Senior Member
Posts like a Northstar
Thread Starter
 
Nobotada84's Avatar
 
Join Date: Apr 2009
Location: Indianapolis, Indiana
Posts: 699
Thanks: 0
Thanked 0 Times in 0 Posts
Nobotada84 is on a distinguished road
Default

Ok so time for another update. So the last time, my mechanic friend had found a leak under the supercharger gasket. (Still waiting for the new gasket.) Anyways today i took the car for an alignement. Can someone please tell me why after the alignement, the engine light went off and the car now drives better than it has in months? now let me preface this by saying that every time prior to this that the engine light went off, the car would continue to run like crap(weird idle and what not) and eventually the light would return. also as it has been runnin lean my fuel economy has been through the roof. however this time, the light went off, the idle smoothed out and my fuel economy has gradually dropped back to what it was before this whole nightmare began. now im no idiot so i know the alignement didnt caue this new revelation, but you gotta admitt that the timing is pretty amazing. now i should also mention that thursday i changed the throttle position sensor. however after the install it still ran rough and the light was still on. likewise prior to the alignement the light was still on and it was still running rough. i have to say this has been the most bizzare code i've ever dealt with on any car. like i said still got a new SC gasket comin and since i've already paid for it, still plan on goin through with the gasket swap. as for right now she'* running pretty good. i have no idea what to make of this. let me know what you guys think.
Nobotada84 is offline   Reply With Quote
Old 04-18-2011, 04:20 AM   #20
Senior Member
Posts like a Northstar
Thread Starter
 
Nobotada84's Avatar
 
Join Date: Apr 2009
Location: Indianapolis, Indiana
Posts: 699
Thanks: 0
Thanked 0 Times in 0 Posts
Nobotada84 is on a distinguished road
Default

Hopefully this will be my final up date on this issue. Last time i was talking about doing a supercharger gasket swap. well that has finally been done. have a look at what we found.

Name:  Gasket1.jpg
Views: 0
Size:  72.7 KB

GAsket looks pretty much shot, but thats not even the best part.

Name:  Gasket2.jpg
Views: 0
Size:  42.6 KB

yes that is a rip in the gasket. No clue how it got there, but i do know it wasnt there when i put it in. Im thinkin when i had my accident, my car was left at a pretty steep incline(sideways) dont know if it is possible for some coolant to have overun the LIM and swamped the gasket, (only thing i can think of) and made it all soggy.

anyways the projecty was a success. No more rough idle, but more importantly no more P0171. heres a few pics of the engine bay all put back together and with new valve covers. the rear cover had been leaking for a while so i finally decided to knock it out while the engine was in pieces.

Name:  Engine1.jpg
Views: 0
Size:  90.7 KB

Name:  engine2.jpg
Views: 0
Size:  22.2 KB
Nobotada84 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
weird weird and really weird 3064datazz 1992-1999 42 07-19-2007 02:03 PM
Weird idle captainmiller 1987-1991 6 12-23-2005 12:05 AM
Weird Idle Boost aCiD 1992-1999 18 08-04-2004 07:16 PM
'00SSEi:rough idle,high idle...Please Help.... GTP2SSEi General GM Chat 2 07-29-2003 01:46 PM
Idle idle or wacky tach? 94bonne98 1992-1999 6 01-31-2003 12:03 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:33 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.