Surging? - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-25-2010, 03:12 PM   #11
Member
Posts like a V-Tak
Thread Starter
 
jnoetzelmann's Avatar
 
Join Date: Mar 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
jnoetzelmann is on a distinguished road
Default

Changed the plugs and wires last night. (Had to get intimate with my Bonnie, my forearms are sore) All plugs had good color but worn out. #4 and #6 wires were in bad shape where they attach to the spark plug. Will post results after test drive.
jnoetzelmann is offline   Reply With Quote
Old 03-26-2010, 03:35 AM   #12
Member
Posts like a V-Tak
Thread Starter
 
jnoetzelmann's Avatar
 
Join Date: Mar 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
jnoetzelmann is on a distinguished road
Default

Replaced plugs and wires last night. Just test drove the car and still have the surging but seems not quite as bad. Definitely more power but surging occurs anywhere from 45-60 mph and at approx 2000rpm under load. When I hit the gas the tc unlocks from OD and all is well. Didn't have the problem in 3rd gear but test drive was only 15 minutes. Still have several items to check/ change

Rechecked coil primaries, tested ok. I had my meter set to the wrong scale (DUH) Pulled the EGR, pintle moves freely, FPR checks ok. So I have yet to check numbers 2,4,6 injectors and harness, MAP sensor (why not), fuel pressure at rail, blocked cat, change FF and O2 sensor (last resort).

Last edited by jnoetzelmann; 03-26-2010 at 05:50 AM. Reason: Updated
jnoetzelmann is offline   Reply With Quote
Old 03-26-2010, 02:28 PM   #13
Member
Posts like a V-Tak
Thread Starter
 
jnoetzelmann's Avatar
 
Join Date: Mar 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
jnoetzelmann is on a distinguished road
Default

Let'* assume for a moment that the transmission valve body in my Bonnie is wearing out the TCC bore. Shouldn't the computer still generate a trouble code? Would a shift kit alleviate this? That problem as I understand should have fixed on 2000 and newer Bonneville'*.
jnoetzelmann is offline   Reply With Quote
Old 03-29-2010, 12:48 AM   #14
Member
Posts like a V-Tak
Thread Starter
 
jnoetzelmann's Avatar
 
Join Date: Mar 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
jnoetzelmann is on a distinguished road
Default

Update- Changed Fuel filter, Fuel pressure checks ok 42psi at idle, raises and lowers with throttle input. That just leaves the o2 sensor, map sensor, blocked cat or possibly a pcm wiring problem or a transmission problem.

If anyone has Ideas or thoughts as to what might be going on or what to look at next please speak up.
jnoetzelmann is offline   Reply With Quote
Old 03-29-2010, 02:35 AM   #15
Senior Member
Certified GM nut
 
SignOfZeta's Avatar
 
Join Date: Mar 2005
Location: New Milford, CT
Posts: 2,284
Thanked 16 Times in 13 Posts
SignOfZeta has a spectacular aura aboutSignOfZeta has a spectacular aura about
Default

My car has this exact same problem. I recently changed the MAP sensor (because it died, not to fix this), and the surging remains. It'* about $40 at AutoZone; save your money.

Replacing the O2 sensors may not do anything, but they should be replaced every 60,000 miles. Avoid Bosch.
SignOfZeta is offline   Reply With Quote
Old 03-29-2010, 04:44 AM   #16
Member
Posts like a V-Tak
Thread Starter
 
jnoetzelmann's Avatar
 
Join Date: Mar 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
jnoetzelmann is on a distinguished road
Default

Quote:
Originally Posted by SignOfZeta View Post
My car has this exact same problem. I recently changed the MAP sensor (because it died, not to fix this), and the surging remains. It'* about $40 at AutoZone; save your money.

Replacing the O2 sensors may not do anything, but they should be replaced every 60,000 miles. Avoid Bosch.
Thanks for the feedback. I'm beginning to think that I have a tranny problem because the engine runs so smoothly. It acts like the TC is trying to unlock when the engine is under load and needs to downshift. When I push the gas pedal down some more it drops in to a lower gear no problem. I'm still going to check out a few more things on the engine but I need to find someone with a tech II so I can look at the tranny specifically when I have the surging.
jnoetzelmann is offline   Reply With Quote
Old 03-29-2010, 10:51 AM   #17
Senior Member
Certified GM nut
 
SignOfZeta's Avatar
 
Join Date: Mar 2005
Location: New Milford, CT
Posts: 2,284
Thanked 16 Times in 13 Posts
SignOfZeta has a spectacular aura aboutSignOfZeta has a spectacular aura about
Default

Quote:
Originally Posted by jnoetzelmann View Post
I'm still going to check out a few more things on the engine but I need to find someone with a tech II so I can look at the tranny specifically when I have the surging.
Yeah, you'll need that or any scanner that checks TCC parameters — mainly slip. Advance doesn't have anything that fancy (to borrow, at least).
SignOfZeta is offline   Reply With Quote
Old 03-30-2010, 08:33 PM   #18
Member
Posts like a V-Tak
Thread Starter
 
jnoetzelmann's Avatar
 
Join Date: Mar 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
jnoetzelmann is on a distinguished road
Default

Well it'* official, the Torque converter is T/U...
jnoetzelmann is offline   Reply With Quote
Old 03-30-2010, 10:07 PM   #19
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

If the torque converter is bad and you need another one, I have 2 stock stall converters sitting on the shelf.
Danthurs is offline   Reply With Quote
Old 03-30-2010, 10:37 PM   #20
Member
Posts like a V-Tak
Thread Starter
 
jnoetzelmann's Avatar
 
Join Date: Mar 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
jnoetzelmann is on a distinguished road
Default

How much shipped to 98258? PM with reply.
jnoetzelmann is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Surging upon startup??? need help Jrios 2000-2005 6 01-24-2004 11:08 AM
Tranny Problem, "Surging" jonboll 1992-1999 12 06-24-2003 02:44 PM
1993 Bonnie driveability issue - surging on light accel Blackstar 1992-1999 10 06-07-2003 10:37 PM
Surging and Hesitation Pontiac735 General GM Chat 18 05-15-2003 09:38 PM
surging, hesitation only when cold oldfrt46 1992-1999 6 11-07-2002 04:25 PM


Tags
car surging, surging

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:56 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.