speedo stuck at 110 - now unstuck but 25mph over true - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-19-2011, 08:23 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Nov 2009
Posts: 74
Thanked 0 Times in 0 Posts
03SLE-SteelBlue is on a distinguished road
Default speedo stuck at 110 - now unstuck but 25mph over true

A few days ago, after a heavy snow, I drove one mile and then tried merging into 70mph traffic. The car got up to speed fine as usual but then my front end started making noises and my steering wheel started shaking. Deciding to slow down and get ready to pull over, I glanced at the speedometer. It read 110mph !! I tried slowing more, then accelerating, no matter what I did it was still 110. I was about to stop at a garage to check out the shaking but it mostly abated, and I continued on to my doctor appointment. I got into 40mph traffic and now the reading came down to 70mph. My guess was hard snow in my front wheel wells. After the doctor I checked it and kicked out the snow packs. I could also see snow beyond the wheel wells but couldn't reach it. Driving next was entirely free of any shakes or noises.

But, the speedometer is still reading 25mph over true whenever I get above 20 true mph. Is there a quick fix for this or is it time to replace some expen$ive parts?
03SLE-SteelBlue is offline   Reply With Quote
Old 01-19-2011, 09:32 AM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Let'* get together and see what the sensor is posting to the pcm as speed. That should suggest a starting point.
BillBoost37 is offline   Reply With Quote
Old 01-19-2011, 01:32 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Nov 2009
Posts: 74
Thanked 0 Times in 0 Posts
03SLE-SteelBlue is on a distinguished road
Default

I'll try to remember to call you tonight, 860-749-8xxx
Otherwise, call me. Henerey in MA at anywho.com
03SLE-SteelBlue is offline   Reply With Quote
Old 01-19-2011, 01:52 PM   #4
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Rob, that'* the house phone. You're lucky to ever catch me inside. Use the number I just texted you from.
BillBoost37 is offline   Reply With Quote
Old 01-27-2011, 05:39 PM   #5
Guest
Posts like a V-Tak
 
Join Date: Jun 2009
Location: Lancaster, PA USA
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Lytninrod is on a distinguished road
Default

So, I don't suppose that you accidently pushed the E/M button in the center of the dash?!? It toggles your readings between "English" and "Metric", thusly Miles Per Hour becomes Kilometers Per Hour, and gives you readings similar to what you are describing. Look at the speedometer to confirm that the the "MPH" is lit up.....I did this once, it stumped me for several hours one day........

Michael
Lytninrod is offline   Reply With Quote
Old 01-27-2011, 07:31 PM   #6
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Nov 2009
Posts: 74
Thanked 0 Times in 0 Posts
03SLE-SteelBlue is on a distinguished road
Default

I bet that'* IT! Ever since that day my mph is in kph, etc etc. All my digital reads are in metric. I'll have to look for that E/M button.

And Bill, if you see this, I'd decided to wait until there was More wrong, I could've lived with the speedo.






i
03SLE-SteelBlue is offline   Reply With Quote
Old 01-28-2011, 07:48 AM   #7
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Rob...no worries. I've fixed the metric/english problem on a friends car before. (wink wink)

There'* a button to the right of your cluster that does it.
BillBoost37 is offline   Reply With Quote
Old 02-01-2011, 03:01 PM   #8
Guest
Posts like a V-Tak
 
Join Date: Jun 2009
Location: Lancaster, PA USA
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Lytninrod is on a distinguished road
Default

Quote:
Originally Posted by Lytninrod View Post
So, I don't suppose that you accidently pushed the E/M button in the center of the dash?!? It toggles your readings between "English" and "Metric", thusly Miles Per Hour becomes Kilometers Per Hour, and gives you readings similar to what you are describing. Look at the speedometer to confirm that the the "MPH" is lit up.....I did this once, it stumped me for several hours one day........

Michael
It'* a fun button to play with, when no one is looking , I give it push, then say "Hey look! We are going 120mph!!" It gets some interesting reactions from my passengers.........i get bored sometimes.....
Lytninrod is offline   Reply With Quote
Old 02-01-2011, 04:19 PM   #9
Senior Member
Posts like a Northstar
 
bo58gardner's Avatar
 
Join Date: Apr 2010
Posts: 518
Thanks: 0
Thanked 0 Times in 0 Posts
bo58gardner is on a distinguished road
Default

I did that too my mom in her prius once, shes going like ~30 and i go "mom why you going so fast" she goes "Holy **** what the hell?!" and then I reveal the button lol all around
bo58gardner is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
But, but, my engine wont turn over. Danthurs General GM Chat 4 02-10-2011 04:15 PM
supercharger stuck on!*UNSTUCK* Ryno02 2000-2005 7 01-06-2008 09:59 PM
speedo stuck a 50mph L27Buick 1992-1999 9 05-18-2004 09:43 PM
oil pressure is hiting 110 psi help !!!!! rwe62382 1992-1999 17 04-24-2004 09:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:16 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.