Oil Pressure gauge doesnt work - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-09-2008, 04:54 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
02SpcGhst's Avatar
 
Join Date: Feb 2007
Location: Columbus, Ohio
Posts: 254
Thanks: 0
Thanked 0 Times in 0 Posts
02SpcGhst is on a distinguished road
Default Oil Pressure gauge doesnt work

Last night i was driving in the rain and i hit a huge puddle on my passenger side and all of a sudden my car chime or whatever its called started going off, i look at the DIC and it says check gauges Oil. I look at the oil gauge and its reading 0 and its stuck at 0. Thought if i turned the car off and and on again it would go away, but didnt work. Would anyone know what the problem may be? A fuse maybe? Im gonna go look at the fuses.
02SpcGhst is offline   Reply With Quote
Old 07-09-2008, 05:03 PM   #2
Senior Member
Posts like a Turbo
Thread Starter
 
02SpcGhst's Avatar
 
Join Date: Feb 2007
Location: Columbus, Ohio
Posts: 254
Thanks: 0
Thanked 0 Times in 0 Posts
02SpcGhst is on a distinguished road
Default

btw, im not sure if its the oil sending unit or not but i replaced this about 3000 miles ago and the part was by gp sorenson if that means anything...THANKS
02SpcGhst is offline   Reply With Quote
Old 07-10-2008, 08:24 AM   #3
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

I would pull the tire and double check to ensure you have a good connection. Might have come unplugged. When the senders go bad, the usual fault is a pegged gauge.
BillBoost37 is offline   Reply With Quote
Old 07-10-2008, 04:11 PM   #4
Senior Member
Posts like a Turbo
Thread Starter
 
02SpcGhst's Avatar
 
Join Date: Feb 2007
Location: Columbus, Ohio
Posts: 254
Thanks: 0
Thanked 0 Times in 0 Posts
02SpcGhst is on a distinguished road
Default

is it supposed to snap into place?
02SpcGhst is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
oil pressure gauge jumping and check oil light on bonnevillebaby Pontiac 27 01-03-2013 01:28 PM
1995 SE--burning oil, low oil pressure gauge. AeroCoupeSS87 1992-1999 2 12-10-2007 09:52 PM
Installed aftermarket HU, now sunroof doesnt work Vio_late Audio (and aftermarket electronics) 0 04-06-2004 05:13 PM
Installed aftermarket HU, now sunroof doesnt work Vio_late Audio (and aftermarket electronics) 0 04-06-2004 05:12 PM
delay doesnt work bonnieman92 Everything Electrical & Electronic 3 03-02-2004 11:51 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:59 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.