Driver's Door / Ground Buss? - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-09-2009, 01:30 AM   #11
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Feb 2009
Location: Savannah, GA
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
hal brodmann is on a distinguished road
Default

O.K., I found that one and everything there looks good. I've cleaned the switch again, and now nothing works. No seat memory, no mirors, no windows work even using their own switches, no door lock, nothing.
What to do next?
hal brodmann is offline   Reply With Quote
Old 04-09-2009, 02:06 AM   #12
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

Quote:
Originally Posted by hal brodmann View Post
There is a ground bus mounted to the A pillar right by the hood latch handle. Is that it.
Yep..that would be it. Mine is closer to the door sill, on the A-Pillar just above the floor pan.
Purplehazeir is offline   Reply With Quote
Old 04-09-2009, 01:33 PM   #13
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Feb 2009
Location: Savannah, GA
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
hal brodmann is on a distinguished road
Default

Seems like a much better idea than earlier models. High and dry! Now that we've figured that out, any more suggestions. I went a few hours with windos and mirrors going up and down by themselves, and now nothing works. All windows down and no way to get them up. Seat memory not working and no windows, doorlocks or power mirrirs working. Ground bus is clean and pretty.
I think I may have caused the problem by cleaning the controls with WD40. Could I have taken a small problem and made it worse?
Please give me some suggestions on what to do next.
hal brodmann is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 SSE, Crank but NO start, Ground BUSS? iwin12 Everything Electrical & Electronic 2 12-17-2008 07:24 AM
Gauge Cluster Help... Tried Cleaning connecions+Ground buss. xDRx Everything Electrical & Electronic 9 07-26-2007 12:07 PM
Ground Buss cleaning emceepecks Everything Electrical & Electronic 13 10-18-2006 04:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:47 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.