Compass Calibration problem - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-22-2005, 09:18 AM   #11
Senior Member
Posts like a Camaro
 
Join Date: Sep 2003
Location: Bad Axe,MI.
Posts: 1,025
Thanks: 0
Thanked 0 Times in 0 Posts
daman is on a distinguished road
Default

It very well could be, take a look and compair them.
daman is offline   Reply With Quote
Old 10-06-2005, 10:49 PM   #12
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Apr 2005
Location: Niagara Falls Ontario Canada
Posts: 1,121
Thanks: 0
Thanked 0 Times in 0 Posts
brianj is on a distinguished road
Default

It'* still chiming with an 148 code on the dic. The compass goes from working properly to chiming every so often it goes away for a few days then chimes again. Gotta be something loose or bad somewhere. Good idea about switching with another ssei, any one close too Niagara Falls Ontario??? LOL. Problem is its intermittant so a module switch may not show up right away as the solution. Still going nuts from the chiming.
brianj is offline   Reply With Quote
Old 10-07-2005, 12:22 PM   #13
Senior Member
Posts like a Turbo
 
Join Date: May 2005
Location: Stockton, CA
Posts: 251
Thanks: 0
Thanked 0 Times in 0 Posts
hvactech is on a distinguished road
Default

Quote:
Originally Posted by brianj
It'* still chiming with an 148 code on the dic. The compass goes from working properly to chiming every so often it goes away for a few days then chimes again. Gotta be something loose or bad somewhere. Good idea about switching with another ssei, any one close too Niagara Falls Ontario??? LOL. Problem is its intermittant so a module switch may not show up right away as the solution. Still going nuts from the chiming.
Mine does the same thing....let me know if you come up with anything.
hvactech is offline   Reply With Quote
Old 10-07-2005, 01:07 PM   #14
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Apr 2005
Location: Niagara Falls Ontario Canada
Posts: 1,121
Thanks: 0
Thanked 0 Times in 0 Posts
brianj is on a distinguished road
Default

Quote:
Is your compass direction not accurate as indicated, or are you having problem with just the chime. If Compass is ok I would just disable the chime and get on with my life.

Problem is Ted that when the thing chimes it reads an EXP code 148 on the DIC so what ever mode the DIC is in it goes to "Calibrate Compass" on the display, so there'* a little more to the fix than just dicsonecting the chime. Either the compas works fine or is goes blank when the error code shows up. On a half hour trip it will do this off and on 5-10 times!
brianj is offline   Reply With Quote
Old 07-05-2006, 12:16 PM   #15
Member
Posts like a V-Tak
 
Join Date: Jan 2006
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
zr1 nsx ssei is on a distinguished road
Default compass

would love to here how to correct this problem. Mine says requires calibration also, but when I follow the instructions, it will acknowledge calibration complete but the compass does not work correctly. The zone is set properly, but the reading is still way off, however the compass calibration warning has gone away. If I am heading due North and then make a u-turn, it will still read North. Very intermittant.
zr1 nsx ssei is offline   Reply With Quote
Old 07-05-2006, 12:18 PM   #16
Member
Posts like a V-Tak
 
Join Date: Jan 2006
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
zr1 nsx ssei is on a distinguished road
Default compass

Sorry, should have read "would love to hear
zr1 nsx ssei is offline   Reply With Quote
Old 07-05-2006, 12:19 PM   #17
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Do you have aftermarket speakers, subs, or amps in the trunk? A large metal toolbox?
willwren is offline   Reply With Quote
Old 07-05-2006, 12:35 PM   #18
Senior Member
Posts like a Camaro
Thread Starter
 
Join Date: Apr 2005
Location: Niagara Falls Ontario Canada
Posts: 1,121
Thanks: 0
Thanked 0 Times in 0 Posts
brianj is on a distinguished road
Default

Quote:
Originally Posted by willwren
Do you have aftermarket speakers, subs, or amps in the trunk? A large metal toolbox?
Nothing but the oem bag, trunk net, and a pail full of carwashing stuff (no metal).
Still does it but not as often. This past winter it went away, but as soon as the warm weather came back so did the problem, although not as often right now........so I'm figuring on a loose wire or ground somewhere in the trunk that is softer now with the warmer temps. When I disconnect the module obviously the problem goes away, but then of course the compass no lonnger works.
brianj is offline   Reply With Quote
Old 07-08-2006, 02:20 PM   #19
Member
Posts like a V-Tak
 
Join Date: Jun 2005
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
ozarkirish87 is on a distinguished road
Default

I have a single 12" sub in mine and had the same problem as you. I also got sick of driving around in circles in parking lots (could the turning radius of this car BE any larger??) so I just decided to live with it for awhile. Here'* the strange thing...it went away. It went away for good! One morning I got up, went out to my car, started her up and expected to hear the chime, but nothing happened. The compass works perfectly and I haven't had a problem since. That was almost a year ago. Maybe if you just let it go for a little while the compass will calibrate itself? Mine did NOT throw a code to the DIC so this may not be applicable to you, but it was my experience. Just my 2 cents.
ozarkirish87 is offline   Reply With Quote
Old 07-08-2006, 04:36 PM   #20
Senior Member
True Car Nut
 
Join Date: Feb 2006
Location: Delaware & Long Island NY
Posts: 3,239
Thanks: 0
Thanked 0 Times in 0 Posts
Shadow is on a distinguished road
Default

My previous 05 GXP used to need to be calibrated every so often but no code showed on the DIC...it would just say calibrate compass....once a month i had to do it i think.
Shadow is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Compass calibration procedure Toddster Electrical 0 01-17-2009 06:58 PM
Compass Calibration. ddalder Everything Electrical & Electronic 11 02-19-2007 12:03 AM
Need Some Help Here Compass Calibration!!! BrianHag General GM Chat 13 05-24-2005 12:02 AM
Compass Spot Ideas...... (getting rid of the compass) Merlin 91/97 Everything Electrical & Electronic 10 11-15-2004 12:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.