03 sle Bonneville - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-03-2011, 05:48 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
shortbus32's Avatar
 
Join Date: Nov 2011
Location: Alabama
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
shortbus32 is on a distinguished road
Smile 03 sle Bonneville

hey guys just bought a 03 SLE and am in the process of restoring it to as close to new as i can , in the trunk the hard plastic cover that goes up against the back seat is missing .

What is this called ? any idea where i could find a used one ?

2nd . It vibrates bad under acceleration or even just rolling 4 to 5 mph but is smooth coasting, I'm guessing a axel out of balance or either a front hub assembly ?

3rd. the abs , trac , and brake light is on hooked it up to computer and it will not communicate with abs , mechanic suggested the " abs module" which is like 1000 bucks or i found one used at a junk yard for 125.00 , question is since the wheel hubs have abs sensors could a cpl new hubs fix the problem ? thanks guys for any help !!

I think i got a good deal in this car it is a 03 with 218k miles 1 owner a nurse that drove 90 miles 1 way to work , and i only paid 2200 out the door from a used car lot it seems to be booking around 5800.
shortbus32 is offline   Reply With Quote
Old 11-03-2011, 11:44 AM   #2
Member
Posts like a V-Tak
Thread Starter
 
shortbus32's Avatar
 
Join Date: Nov 2011
Location: Alabama
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
shortbus32 is on a distinguished road
Default

Did I post this in the wrong location ?
shortbus32 is offline   Reply With Quote
Old 11-03-2011, 12:01 PM   #3
Senior Member
True Car Nut
 
sawgunner's Avatar
 
Join Date: Jan 2009
Location: Dover, NH
Posts: 7,122
Thanks: 0
Thanked 0 Times in 0 Posts
sawgunner is on a distinguished road
Default

yup but no worries i just put it in the proper section for you.

the trunk piece can be had out of any 2000+ bonnie that you may find at a junk yard.

far as the vibration under acceleration you can check the hubs by jacking the front wheels up 1 at a time and try to wiggle it from the 12 and 6 positions if there is any play then the hub is bad. play from 3 and 9 usually means tie rod ends. not saying it couldn't be the axels however the smooth cruising seems to point me away from that.

also are there any check engine lights on?

yes the hubs could cause the abs lights and such but if the tech says abs module they are usually correct. just make sure if getting one from the yard that it'* RPO codes match your car
sawgunner is offline   Reply With Quote
Old 11-03-2011, 04:38 PM   #4
Member
Posts like a V-Tak
Thread Starter
 
shortbus32's Avatar
 
Join Date: Nov 2011
Location: Alabama
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
shortbus32 is on a distinguished road
Default

Thanks so much ! ill get with him in a few days as soon as I figure out what I need, thanks
shortbus32 is offline   Reply With Quote
Old 11-03-2011, 04:43 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
shortbus32's Avatar
 
Join Date: Nov 2011
Location: Alabama
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
shortbus32 is on a distinguished road
Default

no check engine lights are on , just the trac , abs and brake light and when i hit the traction button nothing happens , as soon as i get old faithful out of the shop ( 95 Lincoln town car) " switching rear end from air bags to springs and shocks" ill put the Bonneville in the shop and start narrowing down the problem and ill keep the progress posted here , thanks again guys
shortbus32 is offline   Reply With Quote
Old 11-10-2011, 04:45 PM   #6
Member
Posts like a V-Tak
Thread Starter
 
shortbus32's Avatar
 
Join Date: Nov 2011
Location: Alabama
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
shortbus32 is on a distinguished road
Default

ok , broke left front axle Sunday had to be towed , today replaced both axles both wheel hubs and new rotors and pads , vibration is gone, noticed rear tires are cupping out not sure if just cheap tires (nexon) directional * had water leak turned out to be the top plastic tube coming out of intake beside the idler pulley so removed it and replaced both tubes for 4.95 cent added black silicon to it for extra measure no more leaks , total parts for front end was 352.00 got every thing done for 120.00 labor , god i love this car at full throttle it will smoke both front tires shifting into 2nd gear ( automatic)
shortbus32 is offline   Reply With Quote
Old 11-10-2011, 04:46 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
shortbus32's Avatar
 
Join Date: Nov 2011
Location: Alabama
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
shortbus32 is on a distinguished road
Default

forgot to add trac , abs and brake light is still on
shortbus32 is offline   Reply With Quote
Old 11-11-2011, 08:54 AM   #8
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

rear cupping is ussually bad struts, and have someone with the proper scanner see what the codes are for the abs there are alot of things that could be wrong.
jwfirebird is offline   Reply With Quote
Old 11-11-2011, 10:45 AM   #9
Member
Posts like a V-Tak
Thread Starter
 
shortbus32's Avatar
 
Join Date: Nov 2011
Location: Alabama
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
shortbus32 is on a distinguished road
Default

when you say struts are you talking about this same thing as the air assisted shocks ?
shortbus32 is offline   Reply With Quote
Old 11-11-2011, 10:47 AM   #10
Senior Member
True Car Nut
 
sawgunner's Avatar
 
Join Date: Jan 2009
Location: Dover, NH
Posts: 7,122
Thanks: 0
Thanked 0 Times in 0 Posts
sawgunner is on a distinguished road
Default

ya the air shocks or front struts being bad will cause uneven tire wear as well as cup the tires. alignment has a good deal to do with it as well.

cupped a brand new set of tires on my imp because of an improper alignment
sawgunner is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Will a 95 SLE exhaust manifold fit on my 99 SLE? radomirthegreat General GM Chat 6 03-28-2008 01:10 AM
Purchased a new 2004 Bonneville SLE 95SLE Lounge 9 04-12-2004 10:59 AM
1999 Bonneville Sle gettin horrible gas milage wasnotwas25 1992-1999 3 01-17-2004 11:51 PM
Can anyone identify these problems 2000 Bonneville SLE mspiro 2000-2005 8 01-17-2004 12:47 PM
2003 SLE Exhaust - On A 1999 SLE? toxictelevision Performance, Brainstorming & Tuning 3 02-23-2003 07:41 AM


Tags
3 questions about 03 sle

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:38 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.