02 bonne trans issues - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-12-2011, 02:12 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
02 jim is on a distinguished road
Default 02 bonne trans issues

02 Bonneville le 143k+ miles, lost the overdrive & cruise @ the same time. I travel for wok so I ended up putting another tranny in w/ only 80k. On occasion, it will work, there'* a noticable hard clunk into gear & I can tell that everything shifts - just a little hard, as long as I don't turn the car off I could drive the car all day. Now the car won't shift out of 2nd gear,(@ first I was unplugging the top elect. plug on the tranny, sprayed it w/ contact cleaner & that "seemed" to do the trick, now not so much) I've swapped out computers (had it reprogrammed) & it'* still not commanding 3rd. 1810 came up as a code- has to do with the positioning switch connected to the linkage that the cable connects to. do i pull the this tranny out & fix that or just get the old one fixed (4th gear clutch)
02 jim is offline   Reply With Quote
Old 03-12-2011, 02:38 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Check the fuse marked Misc engine/cruise, or may say OBD Sounds like that fuse went out. I believe your car has one box under the hood, and another under the rear seat.
Danthurs is offline   Reply With Quote
Old 03-13-2011, 12:01 AM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
02 jim is on a distinguished road
Default

With the replacement unit installed, I regained cruise & 4th- when it shifts out of 2nd. I thought that fuse may be suspect, checked it- swapped it w/ another fuse, still n/a. i had the orginal unit scanned, & I got the impression that the 4th gear "spline clutch" or cable may have stripped out? was quoted just as much as the cost of a replacement...through "a friend of a friend". (<300$)

What causes the 2nd- 3rd shift not to command 3rd?

Do I spend another 150 on a flush & filter?

Pull this trans out, get the 4th gear issue with the orig fixed & re install?

on a thin branch, replace the mass air filter sensor "just cause"???

The car is in GREAT cond, no rust, I've only owned it a little over a year (the tags JUST came due) - besides a few radio/heater control light out....
02 jim is offline   Reply With Quote
Old 03-13-2011, 04:08 AM   #4
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Don't quote me on this, but if I recall, the cruise and tc lockup only happens if certain engine parameters are met. A misfire may prevent lockup, a P00XX may prevent lockup. Even with other issues, it may prevent the cruise from working also. Kinda like a built in safety system.

P1810 possibilities.
TFP valve position switch signal circuit is open or grounded

TFP valve position switch circuit shorted to another signal

TFP valve position switch is damaged or has failed

PCM has failed

Are you sure you have the correct P code? You may have a faulty shift linkage sensor.
Mike is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Trans removal/engine+trans install yourgrandma 2000-2005 4 11-03-2012 04:34 PM
92-95 ssei trans swap with sse trans 92L67Bonnie 1992-1999 1 09-29-2009 07:49 AM
97 SSE with GP engine and trans - trans ID'd, new questions Slow Learner 1992-1999 10 04-08-2008 11:18 AM
replaced trans line now trans acts up ? LuvmySse 1992-1999 1 12-07-2007 10:07 AM
Revisting My Trans Issue's (Trans shop 2/19/07) Lowrider0308 1992-1999 30 02-19-2007 03:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:00 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.