White smoke billowing - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-16-2005, 12:28 PM   #21
Junior Member
Thread Starter
 
Join Date: Nov 2004
Location: Hermitage, TN
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
eazye187 is on a distinguished road
Default

We replaced the t-stat gasket and the seal, both paper and rubber.

The TB gasket wasn't replaced at first, but once bolted back together, it leaked like crazy all over that lower brace. We took ot back off, replaced the gasket, and still have the small pool of coolant on the manifold. I'm going to reseat and teflon tape the sender this evening and see if that resolves anything. I may need to hit a junkyard for the bolt and see what I find.

Thanks for the help.
eazye187 is offline   Reply With Quote
Old 05-17-2005, 02:14 AM   #22
Senior Member
Posts like a Turbo
 
Join Date: Apr 2004
Location: Sheridan Wyoming
Posts: 210
Thanks: 0
Thanked 0 Times in 0 Posts
57chevythunder is on a distinguished road
Default

-be sure to let us know what you find out that finally fixes it
57chevythunder is offline   Reply With Quote
Old 05-17-2005, 02:15 AM   #23
Senior Member
Posts like a Turbo
 
Join Date: Apr 2004
Location: Sheridan Wyoming
Posts: 210
Thanks: 0
Thanked 0 Times in 0 Posts
57chevythunder is on a distinguished road
Default

-be sure to let us know what you find out that finally fixes it
57chevythunder is offline   Reply With Quote
Old 05-17-2005, 07:15 AM   #24
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Hit a junkyard for the bolt.... are you missing a bolt?
BillBoost37 is offline   Reply With Quote
Old 05-17-2005, 09:35 AM   #25
Junior Member
Thread Starter
 
Join Date: Nov 2004
Location: Hermitage, TN
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
eazye187 is on a distinguished road
Default

Quote:
Originally Posted by BillBost37
Hit a junkyard for the bolt.... are you missing a bolt?
It'* not missing, but it doesn't seem long enough to get down into the lower mainfold to fully seat the upper. I believe if memory serves me correctly, it is back and to the left of the t-stat housing a little bit if you're facing the engine, and was a 15MM bolt. I didn't get time to check it out last night.
eazye187 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Window Deflectors: Dark Smoke or Light Smoke? CARiD CARiD 0 08-12-2015 07:44 AM
White smoke when starting chzhead 1992-1999 20 08-04-2006 03:51 PM
sudden onset missing, P0300 code, and white smoke?? laff66 1992-1999 13 05-23-2006 11:14 PM
Cleaned Tb,now tons of white smoke??? Paulnold 1992-1999 10 02-07-2005 07:37 PM
white smoke 95neongirl 1992-1999 17 05-06-2004 12:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:26 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.