What are signs of crank sensor failure 94 Bonneville NA - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-20-2011, 04:56 AM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
fbodyNATION is on a distinguished road
Default What are signs of crank sensor failure 94 Bonneville NA

Just a couple of questions
1.)What causes a crank sensor to go bad?
2.)What are the symptoms of a bad crank sensor?
3.)How often do crank sensors usually last?
4.)Is this a common problem with all the GM 3800 V6 engines both */C & NA?
Im asking because im having this issue with my 1994 Pontiac Bonneville SLE NA with 82,000 miles on the engine,i owned more than a few GM vehicles with the 3800 v6 from 1990 through 05 both Supercharged and Naturally Aspirated,i never experience this problem before so i need help
fbodyNATION is offline   Reply With Quote
Old 10-20-2011, 07:48 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

heat cycles and age i would assume. usually at first it will randomly not start when you went somewhere like the store or to get gas and try to restart the engine warm. then gradually get worse to sometimes stalling when warm, sometimes wont start at all. most times you dont get any codes. its a common problem for alot of gm'* ( trucks cars 6cyl, 8cyl etc). what are your symptoms?
jwfirebird is offline   Reply With Quote
Old 10-20-2011, 04:18 PM   #3
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

If you engine turns over when you start it, won't start, and you are not getting spark on any of the cylinders, the crank shaft position sensor or the ignition control module are the 2 most likely candidates. If, leading up to the failure you experience the symptoms JW describes, it is likely the CPS.
2kg4u is offline   Reply With Quote
Old 10-22-2011, 12:20 AM   #4
Senior Member
Posts like a Turbo
 
Join Date: Jun 2009
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
kparrent is on a distinguished road
Default

mine went out without any major signs. never stalled or wouldn't start, and all of a sudden one day just wouldn't turn over. It was with the engine warm though
kparrent is offline   Reply With Quote
Old 10-22-2011, 06:59 AM   #5
Junior Member
Thread Starter
 
Join Date: Oct 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
fbodyNATION is on a distinguished road
Default

Quote:
Originally Posted by jwfirebird View Post
heat cycles and age i would assume. usually at first it will randomly not start when you went somewhere like the store or to get gas and try to restart the engine warm. then gradually get worse to sometimes stalling when warm, sometimes wont start at all. most times you dont get any codes. its a common problem for alot of gm'* ( trucks cars 6cyl, 8cyl etc). what are your symptoms?
when driving it will kill but start right up or if im going up a hill or making a sharp turn like on an on ramp the car will kill but it will start right back up with no problem
fbodyNATION is offline   Reply With Quote
Old 10-22-2011, 02:44 PM   #6
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

sounds more like a loose wire, or something but it really hard to tell these things when it only does it for a second. does it cut right off like a switch or spit and sputter some?
jwfirebird is offline   Reply With Quote
Old 10-22-2011, 05:11 PM   #7
Junior Member
Thread Starter
 
Join Date: Oct 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
fbodyNATION is on a distinguished road
Default

No it just cuts off like it isnt getting enough fuel,air or power it doesnt sputter it just cuts off,but it will start right back up like i said
fbodyNATION is offline   Reply With Quote
Old 10-23-2011, 10:27 AM   #8
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

if it cuts off immediately, thats usually electrical or ign related. some kind of wiring losing contact or sensor failure causing it not to spark anymore then coming right back. fuel will make it sputter or fade out.
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Water pump and beginning signs of failure ? 1013jesse Pontiac 3 07-29-2015 12:06 PM
2001 Chevy Express van with crank sensor / cam sensor correlation problems PStan Chevrolet 6 05-08-2014 05:45 AM
Relation of cam sensor to crank sensor. 57lxi 1992-1999 4 07-29-2010 02:27 PM
What may be the signs of a bad crank sensor? rstrunk 1992-1999 42 03-12-2009 08:42 PM
What are the early signs of UIM/LIM failure? two bonnies 1992-1999 11 02-25-2007 03:14 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.