weird problem with 1994 olds 88 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-06-2008, 12:46 AM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
mrblonde108 is on a distinguished road
Default weird problem with 1994 olds 88

have a 1994 it has the plastic intake. It weird what'* wrong. I start it up and there'* like a ticking noise kike an exhaust leak but it ain't the exhaust coming from the side closest to the firewall. It will overheat in 15 seconds flat and start smoking oil. The radiator is empty but the oil doesn't seem to have antifreeeze in it and the engine isn't missing. Last time i poured water in the radiator it came out as fast as i put it in from somewhere on the side of the engine by the firewall. I did a goole search and saw some stuff about cracked manifolds. Anyone have an idea??

I'm thinking either head gasket(but i never seen one shooting water out), freezeplug may have broke, cracked intake,

But i still can't explain the exhaust sounding tick.

thanks all
mrblonde108 is offline   Reply With Quote
Old 02-06-2008, 02:21 PM   #2
Senior Member
Certified GM nut
 
wakefieldl's Avatar
 
Join Date: Dec 2005
Location: dekalb illinois
Posts: 1,916
Thanks: 0
Thanked 0 Times in 0 Posts
wakefieldl is on a distinguished road
Default

the ticking could be a fuel injector
and the leak could be a coolant seal on the back of the motor
or your bleeder valve could be open and you wouldnt know it
wakefieldl is offline   Reply With Quote
Old 02-13-2008, 01:50 PM   #3
Member
Posts like a V-Tak
 
Join Date: Jan 2008
Location: Toledo, Ohio
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
hvacguy is on a distinguished road
Default

follow the hose from the top of your water pump to where it attaches to the engine, see if the fitting that threads into the engine is broken. GM makes these out of plastic, it is a common problem for them to break, they make metal replacement fittings.
hvacguy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Buick Park Ave. weird engine noise jonesy311c Buick 10 05-08-2011 08:33 PM
HUD in 1994 Olds eighty-eight Royale... L67Silhouette Performance, Brainstorming & Tuning 3 12-03-2007 09:58 PM
weird weird and really weird 3064datazz 1992-1999 42 07-19-2007 02:03 PM
1994 Olds LSS stalling randomly, P1406 code - !!Fixed!! EGR KneeHowMa 1992-1999 13 12-18-2006 06:31 PM
Wheel bearing question on a 1994 Olds Royale blitzkrieg2003 Oldsmobile 1 08-11-2005 01:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.