Voltage problem 93 ssei... Questions - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-06-2007, 10:17 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Location: West Michigan
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
beckster is on a distinguished road
Default Voltage problem 93 ssei... Questions

About a week ago I noticed that my lights dim (worse than before) when i brake, listen to music, or even when I give my car a little gas. This past Friday, when I went out to my car, it would not even start. So I had my dad give me a jump, it started up fine and my dad drove it around for a little while then pulled it back into the garage. Later that day it started up fine. Today it did not start again this morning, so my day hooked up the battery charger and the car started. After sitting in the parking lot for an hour It did not start up again. Alex (beckstyle, my bro) gave me a jump and I drove home.

It seems as if the battery isn't holding a charge. Or possibly, the alternator isn't keeping the battery charged. How can I test my alt.? Could my sound system, be causing the issues? My brother is going to do the "Big 3" once the weather gets warmer, and I will most likely be buying a high amp alt. also. Any other ideas?
beckster is offline   Reply With Quote
Old 02-06-2007, 10:59 AM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Disconnect your battery cables. Pull the rubber boots off. How much corrosion do you find hiding in there that you can't see from the outside?

We get a good dozen of these problems each month during the winter. Pull those boots off and clean all the corrosion, then reassemble with dielectric grease. Then do the same at the alternator and each cable ground location.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Voltage questions ChilinMichael Everything Electrical & Electronic 4 08-21-2007 04:13 PM
voltage gauge and alternator problem younghelio2 Everything Electrical & Electronic 9 02-07-2007 11:45 PM
Questions,Questions,Questions.......... dbeast420 Lounge 2 05-06-2006 03:49 AM
SSE88 VOLTAGE PROBLEM panda1956 1987-1991 8 06-26-2004 04:21 PM
Questions questions questions big_boss2010 1992-1999 2 09-06-2003 01:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.