update on my bonne: "fixed" - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-10-2008, 10:47 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
fleettech225 is on a distinguished road
Default update on my bonne: "fixed"

Hi all,
I first posted about temparture problems,, finally figured out the problem,,
damn PCM. (go figure) After i got that one fixed,, my transmission acted up. It would for no reason drop out of lock-up. no fourth or lock-up, only first,second, third, and it would not do it at certain times,, nooooo, it had to be random.

Tranny guy says it'* the valve body. So he'* gonna replace it with an updated one from Sonnex. I'm hoping this will take care of lock-up, cause we are going on vacation middle of April to PA, and I'd like to save on gas.

I'll write an update on this post in a few days after i get my car back.

Thanks for reading and ya'll have a good night
fleettech225 is offline   Reply With Quote
Old 03-10-2008, 11:18 PM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Did this start when you swapped PCM'*? Where did you get the PCM from, and did you use your original eprom, or the one that came with the replacement PCM?
willwren is offline   Reply With Quote
Old 03-10-2008, 11:35 PM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
fleettech225 is on a distinguished road
Default

Hey wiiwren,, Actually the lock-up problem was happening at the same time the ECT sensor was acting up. I replaced the PCM with a remaned one from Carquest, and i did use the old PROM from original PCM.
I was curious if the PROM could of been the problem all along,, but the dealership said more than likely [u]not Tranny guy basiclly said the same thing, since he'* already checked the valve body and changed the TCC solenoid [u]and PWM solenoid.
He said the valve body is wore out inside the bores and pressure is pushing fluid past the pistons causing them to release and not holding. Thats why he'* going with the sonnex valve body update.

Maybe you have more info you can share. I'd surely appreciate it alot.
fleettech225 is offline   Reply With Quote
Old 03-12-2008, 08:47 PM   #4
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
fleettech225 is on a distinguished road
Default

well here we go again,,,

stopped by the tranny place,, he did what he said he was going to do,,
had his main guy drive the car for over an hour,, on his way back to the shop
the guy for some reason or another,, manually shifted down into D and wham
code P0740, (which is the code all this time) Back to the drawing board

I'm wondering if it really is the prom. can anyone tell me if the computer and or prom can be updated or reflashed somehow?

Man,, i wish the problem would just magiclly fix itself.

Thanks for any input!!
fleettech225 is offline   Reply With Quote
Old 03-27-2008, 10:17 PM   #5
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
fleettech225 is on a distinguished road
Default RE:: update on my bonne,,,Thanks

I would like to Thank all on this site for the knowledge you all have here.
My problem with my car dropping out of overdrive, was the computer, (or eprom)
one or both i'm not sure,, i got another computer and prom from another bonne.

My question is: I took the computer from a '94 bonne, with same engine and tranny, will it effect the performance of my '95 bonne. Will it run the same, have the same power, and everything, or will it run the same as the '94 would?


Thank-you for reading and have a great night!!
fleettech225 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine Stumbles on Acceleration --- Fixed--Fixed--Whew! doorunrun Buick 10 03-02-2008 07:54 PM
fixed the hubs and rear struts and still not fixed...HELP ptrfair 2000-2005 8 08-16-2007 11:20 AM
Strut Rubbing - TOTALLY FIXED - *Fixed Pics 2/28/08* wjcollier07 1987-1991 33 06-17-2006 07:57 AM
"Fixed" my airbox (question) NERV General GM Chat 12 01-22-2006 09:22 PM
intake fixed...no more "issues"...except check eng LittleHoov 1992-1999 14 07-09-2005 10:56 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.