three oxygen sensors in ONE year! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-10-2004, 04:13 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Custom88 is on a distinguished road
Default three oxygen sensors in ONE year!

well, Service Engine Soon light came on yesterday for the first time so I took it in to get the codes read.. Oxygen Sensor was the fault once again! This will be my third one I've had in this car in one year.. All of them have been AC Delco too! is there a more reliable brand out there or am I just having bad luck?
Custom88 is offline   Reply With Quote
Old 08-10-2004, 04:17 PM   #2
Junior Member
 
Join Date: May 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
SSEi95 is on a distinguished road
Default

Is there something fouling up the O2? How burnt up do the ends look on them?
SSEi95 is offline   Reply With Quote
Old 08-10-2004, 04:21 PM   #3
Junior Member
Thread Starter
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Custom88 is on a distinguished road
Default

the oxygen sensors are always pitch black when I pull them out. The spark plugs are also black. It really makes no sense though, I still usually get 28-29 MPG until the SES light turned on, then it dropped down to around 23.
Custom88 is offline   Reply With Quote
Old 08-10-2004, 04:22 PM   #4
Senior Member
True Car Nut
 
Join Date: Aug 2003
Location: Salina, KS
Posts: 5,246
Thanks: 0
Thanked 0 Times in 0 Posts
TrueWildMan is on a distinguished road
Default

Quote:
Originally Posted by Custom88
the oxygen sensors are always pitch black when I pull them out. The spark plugs are also black. It really makes no sense though, I still usually get 28-29 MPG until the SES light turned on, then it dropped down to around 23.
Good gas mileage or no, you're still running a bit rich, and that both fouls up O2 sensors and eventually the cat. Check your MAF sensor and TPI.
TrueWildMan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oxygen sensors dakotaduffy 2000-2005 15 03-18-2008 12:20 AM
2 02 sensors or just one? Boreas General GM Chat 4 06-21-2006 10:45 PM
Replaced oxygen sensor. Old one is in an awful condition Serj.ru 1992-1999 20 03-15-2006 04:23 PM
Oxygen Sensors padgett 1987-1991 3 01-10-2005 04:07 PM
Anyone like Bosch oxygen sensors? anthonyv62 General GM Chat 14 09-24-2003 10:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.