Steering column Issues - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-28-2009, 10:50 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jul 2009
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
TLCmyBONNEVILLE! is on a distinguished road
Default Steering column Issues

My Steering column (believe that what it is) is broken i believe, the shaft off to the left from the steering wheel that controls different functions. Im able to activate the left blinker and right blinker windshield wipers and fluid. but when i pull it towards me to turn on high beams, or press cruise control,. nothing happens. It seems extremely loose, and there is plastic missing from around the back side of it. The fuses are all good throught the car, checked 4 fuse boxes.
Is there a switch or something anyone knows of that i can press to get this to work again, or something im not thinking of. Thanks!
TLCmyBONNEVILLE! is offline   Reply With Quote
Old 07-28-2009, 11:21 AM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Take a look at this post from the last couple days. I think it'll help to address some of the questions.

https://www.gmforum.com/t282886/
BillBoost37 is offline   Reply With Quote
Old 07-28-2009, 12:17 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jul 2009
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
TLCmyBONNEVILLE! is on a distinguished road
Default

I looked at that forum previous to posting. It looked like that was just the wiper control. and how to go about getting once via website/gm store w/ part numbers etc... Should i just take it to a shop, have them tell me whats wrong then just fix it myself =P
TLCmyBONNEVILLE! is offline   Reply With Quote
Old 07-28-2009, 02:30 PM   #4
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Having a little experience there...

The high beams is part of the multifunction switch Toddster is talking about and posted the pic. the cruise is a switch on the stalk that sticks out. That could have a problem somewhere else though. Knowing your year would help in this case.
BillBoost37 is offline   Reply With Quote
Old 07-28-2009, 04:58 PM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jul 2009
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
TLCmyBONNEVILLE! is on a distinguished road
Default

It is a 95 SE.

So i need to replace the multifunction Switch maybe?

also the cruise control is a button on the very end of the lever. It use to take 5-7 times of pressing it and making sure my speed was constant for it to kick on, also it would kick on at random times, was quite entertaining, but potentially dangerous. I would just be driving then i would feel the pedal go down and car speed up to always around 70 mph if i didnt stop it, thought it was cute, knew something war wrong, but again though it was amusing. Anyway thats the life of the cruise control..

As for the High Beam, i have to pull the lever towards me for it to activate. When i pulled on it, there would be a click and it would activate the beams. Something happened oneday and now when i pull on the lever to activate it, no click, no resistance what-so-ever. also feels like the lever is loose when pulling it that way. Hope this information helps. Also, just checked all the fuses with a multi meter (under the hood, passanger and driver side) but not the relays. Hope this helps
TLCmyBONNEVILLE! is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
92 riviera steering column issues, please help uisim881988 Buick 0 03-25-2015 11:47 PM
Steering Column Sensor Issues Jayman 2000-2005 23 11-28-2006 06:45 AM
Steering Column bobcaller General GM Chat 2 11-06-2003 05:14 PM
Disconnected Steering column Jacket CyberBonneville 1992-1999 1 06-09-2003 06:12 PM
Loose Steering Column shortstuf212559 1987-1991 1 01-28-2003 10:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.