To start or not to start? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-17-2009, 10:51 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2009
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
sam8772 is on a distinguished road
Angry To start or not to start?

Hey guys I have a 1997 Pontiac Bon SE and have been having one bear of a day with it. First of all check engine light is on. Code read random cylinder misfire other code read rich or lean on one engine bank only. Now when I can get the car to start the acceleration seems to lag a little as I really press on the gas also cause the check engine light to flash while driving. Next once car has been driven for a while it does not want to start. Cranking is not a prob and sometimes it starts but idles very ruff then dies off. If I let it sit for a while sometimes It wil start up with a little ruff idle then things seem to be okay and I am on my way. I have replaced the upstream O2 sensor and have the downstream on the way. However deep down inside I feel that the 2nd O2 sensor is not the problem. Took the mass air flow sensor off and same problem(have not replaced) . I really don't even know how to start troubleshooting this bad boy. It seems everyday brings about a new little problem. Each sensor I read about is racking up some serious change which is growing less and less in my pocket. So do you guys think this sounds like a O2 prob. Maybe a Mass Air Flow Prob, Maybe I just need to scrap it and start with a new car. Any thoughts or suggestions would be greatly appreciated.
sam8772 is offline   Reply With Quote
Old 03-17-2009, 11:00 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Welcome to the Bonneville forum. From what your saying it sounds like you have a vacuum leak. Take a can of carb cleaner and spray it around all your vac lines while the engine is running. Make sure you get the EGR tubs as well. If the RPM jumps up, you found the leak.
Danthurs is offline   Reply With Quote
Old 03-17-2009, 11:04 PM   #3
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

Hi SAM8872 - Welcome to the Bonneville Forum!

Please add your year and trim of your vehicle to your signature line. That way when you start asking questions in other areas of the forum, we all have a better idea on how to assist you. Click on "Quick Links" above, go down to "User Control Panel" and then click on "Edit your Signature" It'* pretty straight forward from there.
Purplehazeir is offline   Reply With Quote
Old 03-17-2009, 11:22 PM   #4
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2009
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
sam8772 is on a distinguished road
Default

Thanks for the quick responce. I did go out there and spray starting fluid around all the vaccum line I could see. I did notice a crack in one of the sleves that plugs into the throttle body. It seems as if it might be sucking some air from there after saturating the crack it finally increased the RPMS. As far as the "EGR tubes" I am not for sure what/where they are. And do you think this small air leak would cause the engine to not start(mainly when its cold 25 below or when the engine is Hot 200 then let set for 20 min no start) THANK YOU so much for all you help and thoughts. In these tough times any little info to save some $ is.. well... just awsome.
sam8772 is offline   Reply With Quote
Old 03-17-2009, 11:29 PM   #5
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

The EGR tubes are on the drivers side rear right behind the throttle body. You will see a tube come out of the rear manifold, then go in to the lower intake manifold.

A vacuum leak can do strange things. So lets get that problem fixed before we start throwing any parts at your car.
Danthurs is offline   Reply With Quote
Old 03-17-2009, 11:42 PM   #6
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2009
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
sam8772 is on a distinguished road
Default

Right on I will get on it as soon as I get home from work tomorrow. Can you buy the vaccum line and fittings at a local parts store? Thanks Again.... I hope I make it to work... If not I will have a "Car Sick" Day. LOL
sam8772 is offline   Reply With Quote
Old 03-17-2009, 11:45 PM   #7
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Ya, just get a package of generic vacuum lines, you get get red, blue, and black. Then just cut them to what ever length you need.
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2nd gear is not right (NOT FIXED, NEED GEARHEADS, LOT O PICS harofreak00 General GM Chat 57 03-29-2005 12:34 AM
not good. NOT GOOD. (hit and run, not bad-BAD, but not good) repinS General GM Chat 13 11-26-2004 11:35 AM
Not a Bonnie,not a Pontiac............. dbeast420 Lounge 3 10-17-2004 12:47 PM
OMG this confuses me so much GRR not battery not alternator? killer_cr80r Lounge 5 08-27-2004 10:23 AM
HEADLIGHTS LEGAL OR NOT WORK GOOD OR NOT LOOK PLZ........... killer_cr80r Lounge 8 05-19-2004 01:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:58 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.