Stall when starting cold - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-20-2007, 10:04 PM   #1
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Sep 2002
Location: Riverton, Wyoming
Posts: 740
Thanks: 0
Thanked 0 Times in 0 Posts
egladman is on a distinguished road
Default Stall when starting cold

Just like the subject says my car will stall when starting cold. Only once and after that it runs great. Idles fine and drives fine. No check engine lights or anything. New plugs and wires and fuel filter. Has always done it since i've bought it.
egladman is offline   Reply With Quote
Old 04-20-2007, 11:00 PM   #2
Senior Member
Posts like a Turbo
 
Join Date: Oct 2006
Location: Whitewater, Wisconsin
Posts: 319
Thanks: 0
Thanked 0 Times in 0 Posts
nicklikesmilk is on a distinguished road
Default

clean the battery cables? am i the first to say it?
nicklikesmilk is offline   Reply With Quote
Old 04-20-2007, 11:47 PM   #3
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Sep 2002
Location: Riverton, Wyoming
Posts: 740
Thanks: 0
Thanked 0 Times in 0 Posts
egladman is on a distinguished road
Default

Just cleaned em in fact I just replaced my battery also.
egladman is offline   Reply With Quote
Old 04-21-2007, 12:50 AM   #4
Senior Member
Certified Car Nut
 
Join Date: Jul 2003
Location: Robbinsdale, MN
Posts: 15,408
Thanks: 0
Thanked 0 Times in 0 Posts
MOS95B is on a distinguished road
Default

Fuel pressure regulator
MOS95B is offline   Reply With Quote
Old 04-21-2007, 08:11 PM   #5
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Sep 2002
Location: Riverton, Wyoming
Posts: 740
Thanks: 0
Thanked 0 Times in 0 Posts
egladman is on a distinguished road
Default

I'm thinking the regulator as well. Is it gonna hurt the car to not change it right away? Like I said earlier the car runs and drives great after the initial start.
egladman is offline   Reply With Quote
Old 04-22-2007, 12:45 AM   #6
Senior Member
Certified Car Nut
 
Join Date: Jul 2003
Location: Robbinsdale, MN
Posts: 15,408
Thanks: 0
Thanked 0 Times in 0 Posts
MOS95B is on a distinguished road
Default

Mine used to do the same thing untilo I changed the FPR. I think we figured out all that was happening was the bad FPR was allowing the fuel to drain back towards the tank, instead of maintaining pressure like it was supposed to.

So, if it is the FPR, then all your doing is putting a little extra effort getting the pressure back up to where it needs to be
MOS95B is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
intermittent weird starting/not starting.... HELP!! jaye22 Everything Electrical & Electronic 15 04-14-2017 08:10 PM
Help! Trouble starting when warm, but not cold? SilverSleeper8704 2000-2005 15 06-09-2010 10:34 PM
Hard starting when cold? Timothy's Buick 1992-1999 4 11-03-2009 01:25 PM
High Idle When Starting, Cold Temperatures ucrm4c 1992-1999 30 01-08-2008 12:20 AM
Long start, short start, long stall, short stall :-( jessie_harbin 1992-1999 3 03-12-2006 11:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.