Seafoaming FAILURE!! ..also tranny leak? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-06-2009, 08:06 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Geforce's Avatar
 
Join Date: Dec 2008
Location: Mississauga Ontario
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Geforce is on a distinguished road
Default Seafoaming FAILURE!! ..also tranny leak?

Well the Seafoam was a complete waist of time.... I sucked up 1/3 in a cup through the brake booster (sry Dan couldnt find the mini vacuum hose near UIM) with my friend under the gas pedal... Waited 15-17min fired her up with no hesitation and thats it.... Then i poured the rest in the gas tank. (NO SMOKE SHOW!!) During the high revving while my buddy was recording an accident happens near us (stupid lady drove into some guys door both while driving).
So we're like screw it we drove to an open parking lot and started screwing around (buddy making donuts, me reverse 180ing). We then went someone to eat, after we were done I COULDNT *****EN Start the DAMN car!!! I couldn't start it to the point where the battery started to fade out. I went to a an auto store to buy some fluids, and after still returning it managed to run on 1 or 2 pistons, so i started pumping and finally got all bangers to fire up. (still no smoke show). went home after a long drive and found out i have almost no tranny oil!!!!!! WTH!

Seafoam had nothing to do with the tranny leak because earlier that month i checked the tranny oil level while the motor was running and so barly so i though to myself it might be because it too cold. But today i check and almost nothing (shows an arrow to fill up to 5L'* to normal fluid level.

Sorry for the novel but im really disappointed with this car...

BTW theres a bit of snow here

Last edited by Geforce; 02-06-2009 at 08:08 PM.
Geforce is offline   Reply With Quote
Old 02-06-2009, 08:15 PM   #2
Senior Member
Posts like a Turbo
Thread Starter
 
Geforce's Avatar
 
Join Date: Dec 2008
Location: Mississauga Ontario
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Geforce is on a distinguished road
Default

Forgot to mention, Got a check engine light after i fired her up from 15min. And when i was sucking this thing in i drowned the engine at the last sip of the seafoam (engine shutoff on its own)
THe light eventually disappeared after screwing around in the parking lot.
Geforce is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
93 LeSabre Front Driver Side Water Leak and back passenger leak Kimberly Buick 37 05-04-2014 03:40 PM
Seafoaming... Geforce 1992-1999 27 01-28-2009 04:23 PM
my 01's laundry list - tranny failure code? ptrfair 2000-2005 2 02-28-2008 07:55 AM
Seafoaming a SSEi..... Bonneville92V688 General GM Chat 12 11-19-2006 02:14 PM
Posted in general chat also.... pontiacfan1978 1987-1991 0 10-24-2002 04:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:53 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.