problemm?????? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-08-2005, 01:21 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2005
Location: Woodbridge, Va
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
SUPRCHRGD is on a distinguished road
Default problemm??????

my low coolant light keeps coming on every so often????
under normal drivng conditions...?

any ideas on what this could be????
SUPRCHRGD is offline   Reply With Quote
Old 10-08-2005, 01:27 PM   #2
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

either its low coolent or there is a sender on the bottom of the rad, on the pass side....check the sender for corrosion or the sender may be faulty
1993 SLE is offline   Reply With Quote
Old 10-08-2005, 01:29 PM   #3
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2005
Location: Woodbridge, Va
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
SUPRCHRGD is on a distinguished road
Default hahhhhhahaha

its not low coolant

ill check
SUPRCHRGD is offline   Reply With Quote
Old 10-08-2005, 03:54 PM   #4
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Pull the sensor out and clean off the part that sticks in the rad. Clean the connector also.
willwren is offline   Reply With Quote
Old 10-08-2005, 07:58 PM   #5
Senior Member
Posts like a Turbo
 
Join Date: Aug 2005
Posts: 235
Thanks: 0
Thanked 0 Times in 0 Posts
optmusprimer is on a distinguished road
Default

I have the same problem, have yet to begin working on it yet though.
optmusprimer is offline   Reply With Quote
Old 10-27-2005, 08:39 AM   #6
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2005
Location: Woodbridge, Va
Posts: 263
Thanks: 0
Thanked 0 Times in 0 Posts
SUPRCHRGD is on a distinguished road
Default

I think the sensor cleaning did it...
it has been a lil over 2 weeks and
low coolant light has yet to come on..

thanx
SUPRCHRGD is offline   Reply With Quote
Old 10-27-2005, 08:47 AM   #7
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Quote:
Originally Posted by SUPRCHRGD
I think the sensor cleaning did it...
it has been a lil over 2 weeks and
low coolant light has yet to come on..

thanx
It'* one of those things that is simple and you wonder why you put up with it.
BillBoost37 is offline   Reply With Quote
Old 10-28-2005, 01:45 PM   #8
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default sensor

thats good to know. My SSE has been doing this for a while. Tried to get the sensor out of the Rad. but was afraid to break the clips and ruin the rad.
Had aftermarket tanks installed, maybe thats why its so hard.
SSEBONNE4EVA is offline   Reply With Quote
Old 10-28-2005, 03:08 PM   #9
Senior Member
True Car Nut
 
Join Date: May 2003
Location: Lethbridge, Alberta, _______Canada._______ West Coast Bonneville Fest ___05,06,07 Survivor___
Posts: 8,134
Thanks: 0
Thanked 0 Times in 0 Posts
SSEimatt93 is on a distinguished road
Default

all ya gotta do is unplug the sensor, thats what i didn in my old one..alot of cars dont even have a low coolant sensor, and since i check that kinda stuff often enough. I left it.
SSEimatt93 is offline   Reply With Quote
Old 10-29-2005, 12:50 PM   #10
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default sensor

so unplugging it turns off the light?
SSEBONNE4EVA is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:43 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.