Power Antenna does not go up or down, but you hear it cycle? - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-04-2005, 03:45 AM   #11
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Honestly I don't see the two as an expected thing. I've had power antennas in many cars and only had one problem. Sounds like Bob had some bad luck with an antenna.
BillBoost37 is offline   Reply With Quote
Old 09-04-2005, 03:01 PM   #12
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

My 93 failed at 10 years old for the first time. I replaced it with a wrecker unit from a 99 for $30.

My 95 failed at 10 years (was when I bought it last month). Ditto on the replacement. 99 from a wrecker for $20.

The 93 has been flawless for 3 years. Why? Because I opened it up, cleaned it, and re-greased it before installation.

I entirely disagree with buying two. I don't see anything out of the ordinary for failure rates on this forum.
willwren is offline   Reply With Quote
Old 09-05-2005, 07:14 PM   #13
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2005
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Falcon123 is on a distinguished road
Default

My mom bent hers in the car wash :(. WHat is that non-powered one and can I have a link. Is it REALLY easy too?
Falcon123 is offline   Reply With Quote
Old 09-05-2005, 07:22 PM   #14
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Quote:
Originally Posted by willwren
My 93 failed at 10 years old for the first time. I replaced it with a wrecker unit from a 99 for $30.

My 95 failed at 10 years (was when I bought it last month). Ditto on the replacement. 99 from a wrecker for $20.

The 93 has been flawless for 3 years. Why? Because I opened it up, cleaned it, and re-greased it before installation.

I entirely disagree with buying two. I don't see anything out of the ordinary for failure rates on this forum.
I agree 100% my 93 has been perfect for 12 years, no problems *knock on wood*...but i clean it, and grease it on a regular basis.....
1993 SLE is offline   Reply With Quote
Old 09-05-2005, 10:06 PM   #15
Senior Member
Posts like a Camaro
 
Join Date: Dec 2002
Location: Northeast MS
Posts: 1,079
Thanks: 0
Thanked 1 Time in 1 Post
94SSEgold is on a distinguished road
Default

we replaced the one in the 94 with one from a 99 last year and it still works effortlessly, got it from the junk yard, for like 15 and just keep it oiled and well maintained
94SSEgold is offline   Reply With Quote
Old 09-07-2005, 11:34 PM   #16
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Jun 2005
Location: Tucson, AZ
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
nick s is on a distinguished road
Default

thanks for all the replies.......
nick s is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Momentary loss of power after high G turn, but engine does not die. Autocross practic CadVetteStang Cadillac 7 11-25-2013 04:16 PM
Power antenna not so power anymore... phoenix_flame220 1987-1991 5 09-03-2007 05:56 PM
Hear Ye, Hear Ye Village Idiots Mike Lounge 16 09-16-2006 08:17 PM
not good. NOT GOOD. (hit and run, not bad-BAD, but not good) repinS General GM Chat 13 11-26-2004 11:35 AM
Deck does not support power antenna. rhalford15 Audio (and aftermarket electronics) 16 04-28-2004 07:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:06 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.