p1640 QDM 1 error....any ideas? ECM has been swapped already - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-20-2008, 07:23 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jan 2008
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
MileHighSSEi is on a distinguished road
Default p1640 QDM 1 error....any ideas? ECM has been swapped already

Well....cleared codes and went on a drive with the Ethos Snap-on Scanner. Neat little tool.

IAC counts never showed below 36.

Previous fault codes were p0341 and that never came back so we look good to go.

HOWEVER......the problem generally has been found...so I need to pick your brains to see whats up.

P1640--QDM-1 Failure. Quad driver module I presume in the ECM.

I already swapped the ECM. No way in hell could 2 be bad?


Also big thing.....I have a brand spankin' new battery in there. Volts show 13.6 or so....but when I turn the A/C on with the Lights on....voltage drops to 12.2!!

Could it be a faulty voltage regulator? Alternator?

How could the electrical cause the motor to not boost at all?

Timing looked excellent BTW....No more than 15 degree at WOT....ranged down to 27 or so. Car doesn't miss or anything. Just has no balls, no boost, crappy mileage, etc.

Thanks a ton!
MileHighSSEi is offline   Reply With Quote
Old 05-20-2008, 08:14 PM   #2
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

You need someone with a 94 FSM to tell you what four devices get power from QDM 1.

Since you're not getting boost we can take a stab in the dark & have you check the resistance of the boost control solenoid.

Have you pulled the rubber boots off the battery cables to check for corrosion on the cable ends? That'* the first place to look when the voltage is dropping.
Technical Ted is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Error Code P1670 QDM questions cspoonts 1992-1999 114 02-05-2010 03:04 PM
QDM 4 Error SPOILEDRED94 1992-1999 3 01-16-2008 01:50 AM
p1640 p1670 error codes smfuller 1992-1999 1 12-18-2007 08:02 PM
Code 26? QDM Error? WTF DrCheeto Oldsmobile 1 10-11-2006 09:56 AM
door panel removal (im sure this has been asked already) c0rsa180 Audio (and aftermarket electronics) 2 02-14-2005 06:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:45 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.