O2 Sensor - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-12-2006, 08:53 PM   #21
Senior Member
True Car Nut
 
Join Date: Dec 2003
Location: Corn Fields, IN
Posts: 2,766
Thanks: 0
Thanked 0 Times in 0 Posts
John Deere Boy is on a distinguished road
Default

My mileage has dropped a few points lately, from 25 to 23 highway, so I pulled mine out.

Good, bad, or ugly? (140,000 miles)


I also regapped my plugs. The front bank was up to .066 but the rear bank was all at 061 or 062. They might still be original but they all still look good.
John Deere Boy is offline   Reply With Quote
Old 05-12-2006, 10:06 PM   #22
Senior Member
Posts like a Turbo
 
Join Date: Mar 2006
Location: Houston, Tx
Posts: 367
Thanks: 0
Thanked 0 Times in 0 Posts
BonnevillesSince62 is on a distinguished road
Default

With 140k miles, you got at least 60k more than you should out of it. Without a doubt replace it!
BonnevillesSince62 is offline   Reply With Quote
Old 05-13-2006, 12:29 PM   #23
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

Agreed.. Time for a new one JDB...

I'm doing 26 in mixed driving... A few miles city, and several highway...

And even an L27 with the 3.06 ratio should pull 30 on the highway

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
A Bad TPS sensor or something else (Throttle position sensor) DeathDealer General GM Chat 17 03-27-2017 10:30 PM
Relation of cam sensor to crank sensor. 57lxi 1992-1999 4 07-29-2010 02:27 PM
p0134 insufficent activity bank 1 sensor 1 oxygen sensor Boostinta 1992-1999 8 06-04-2009 01:41 PM
HELP! cam sensor error... and its NOT the cam sensor Sprig Everything Electrical & Electronic 3 06-17-2006 11:13 AM
IAT sensor integrated in Mass Air Flow Sensor? cballweg Bonneville GXP/ Northstar Powered Cars 6 05-04-2006 03:37 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.