IAT and mileage - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-04-2010, 10:15 PM   #1
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2008
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
nightshade is on a distinguished road
Default IAT and mileage

would gutting ur intake affect ur gas mileage because i get about 10 to 13 in the city and maybe 18 on the highway and i can figure out why ... im going to get the car scanned tomorrow but what will happen if you unplug the iat ?
nightshade is offline   Reply With Quote
Old 01-04-2010, 10:23 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

That was a very old thread so I moved this to it'* own thread.

Leave the IAT sensor plugged in. That information is needed for the PCM to calculate the proper air flow. What year is your car, how many miles. A old O2 sensor can cause bad mileage.
Danthurs is offline   Reply With Quote
Old 01-04-2010, 10:52 PM   #3
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2008
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
nightshade is on a distinguished road
Default

lol yeah i noticed the date on that thread after i posted it but i tested it and its bad but hopefully tomorrow i can get the car hooked up to a scanner i'm pretty sure i have a bad o2 sensor too

the car is 96 bonnie se with l67 swap car has about 190k miles but the motor has about 90k... or so the junkyard says but im also wondering if there maybe something worng with my transmission due to converter full lock up is at 3k other then that the rpms kind float around depending on throttle position.

http://www.freeautomechanic.com/iat-...mperature.html i found this test the ati and found in a 70 degree room there 2.4 k ohm so im going to replace it and see how well my fuel mileage is this weekend ... hopefully this is the problem that'* causing my crappy fuel mileage

Last edited by nightshade; 01-04-2010 at 10:56 PM.
nightshade is offline   Reply With Quote
Old 01-04-2010, 10:53 PM   #4
Senior Member
Posts like a Turbo
 
judgemikdredd's Avatar
 
Join Date: Mar 2009
Location: Clawson, Michigan
Posts: 478
Thanks: 0
Thanked 0 Times in 0 Posts
judgemikdredd is on a distinguished road
Default

couldn't a bad or dirty maf cause bad mileage
judgemikdredd is offline   Reply With Quote
Old 01-04-2010, 10:59 PM   #5
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Not really no. Nothing wrong with cleaning it, but causing bad mileage, no.
Danthurs is offline   Reply With Quote
Old 01-04-2010, 11:11 PM   #6
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2008
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
nightshade is on a distinguished road
Default

well i recently cleaned it but haven't tested but i don't know. 95 percent of my problem could be my car thinks its running a l 36 n/a because i haven't been able to tune the pcm
nightshade is offline   Reply With Quote
Old 01-04-2010, 11:16 PM   #7
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Proper tune is important. Pull your plugs and inspect them. If they are dark, your running rich.
Danthurs is offline   Reply With Quote
Old 01-05-2010, 12:05 AM   #8
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

Quote:
Originally Posted by nightshade View Post
well i recently cleaned it but haven't tested but i don't know. 95 percent of my problem could be my car thinks its running a l 36 n/a because i haven't been able to tune the pcm
That'* probably 100% your problem. The L36 PCM can run the L67 without some changes.
Purplehazeir is offline   Reply With Quote
Old 01-06-2010, 12:08 AM   #9
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2008
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
nightshade is on a distinguished road
Default

well hooked it up to my friends auto tech comp its about 45 outside and the ait is reading 180 so i have the new one on order... and for some reason the map sensor reads 6 hg in and my gauge reads 20 in hg and i hit the gas and it drops to about 16 inches of vac.... any ideas maybe i have a wire crossed from using the map sensor from the gtp ...{ i havent tested it to see if its bad yet but thats on tomorrow agenda} also i noticed at idle my maf sensor is reading 2500 mhz my friend says thats seems rather high but doesnt know to much about gm'*
nightshade is offline   Reply With Quote
Old 01-06-2010, 12:09 AM   #10
Junior Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2008
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
nightshade is on a distinguished road
Default

also im not running rich if anything it seems the plugs are running lean ... so i dont know why im getting 12mpg on a good day ...
nightshade is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
IAT Sensor on 2001? And Computer relocation? VanFaasenC Performance, Brainstorming & Tuning 2 09-21-2006 01:05 PM
IAT sensor and trouble codes bonnevillemac 2000-2005 4 08-28-2005 11:29 PM
IAT sensor and trouble codes bonnevillemac Performance, Brainstorming & Tuning 3 03-11-2005 12:10 PM
IAT and other mods... kaylin4u 1992-1999 2 01-24-2005 01:21 PM
Tricked IAT Sensor 2000SilverBullet Performance, Brainstorming & Tuning 18 09-01-2003 02:39 PM


Tags
3.8. l67, 3800, bonneville, bonnie, iat, maf, ponitiac, rich, se, sle, sse, ssei

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:20 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.