I belive I have found the ELC problem - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-05-2005, 03:41 AM   #11
Senior Member
True Car Nut
 
Join Date: Jan 2005
Location: Montevideo, MN MWBF '05, '06, '07 WCBF '06 '07 survivor
Posts: 3,882
Thanks: 0
Thanked 0 Times in 0 Posts
sonoma_zr2 is on a distinguished road
Default

Hey, I'm going to try to work on my elc today since it is so nice out. Are you saying the 97 ssei compressor is in the trunk? When I hit the button in the trunk I hear a click but that'* it. The car sits level, but when people get in the back, it does not level. The only fuse I can find is in the engine compartment (30 amp) and it'* good. Some specific suggestions for 97 ssei would be great.
sonoma_zr2 is offline   Reply With Quote
Old 02-05-2005, 12:09 PM   #12
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Quote:
Originally Posted by driverjohn2005
here'* the deal. thats a possibility.

there is power going to the unit when I adjusted the sensor in the rear to simulate a load. But the power that is being sent does not start the ELC. But when I do put power to the ELC manualy the compressor kicks on and starts raising the car. In fact, the car is raised a little above the level position right now. I just left the wire connectors apart. If I hooked them back up the air pressure would be let out.
Remember that if the inflator is on, It prevents ELC. And it may be switching a ground, not power. You have to look at your FSM for that (DrJay still has mine).

So if your selector valve is bad, it may be part of the problem.
willwren is offline   Reply With Quote
Old 02-05-2005, 12:42 PM   #13
Senior Member
True Car Nut
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default

Quote:
Originally Posted by sonoma_zr2
Hey, I'm going to try to work on my elc today since it is so nice out. Are you saying the 97 ssei compressor is in the trunk? When I hit the button in the trunk I hear a click but that'* it. The car sits level, but when people get in the back, it does not level. The only fuse I can find is in the engine compartment (30 amp) and it'* good. Some specific suggestions for 97 ssei would be great.
The pump is actually under the car, just behind the rr wheel. Gotta go at it from underneath. My pump in my 1998 SSE had been pretty inactive when it should have been active up until about 1 week ago. Now every time I pop the trunk and put something in or someone climbs in the back seat the pump kicks in for a a couple seconds and the back end comes up noticably, but not overdone.
OLBlueEyesBonne is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
yall aint gonna belive this juggernaut_666_20 Lounge 4 05-21-2006 01:51 AM
I cant belive it! ssesc93 General GM Chat 4 10-08-2004 11:51 AM
HERE!! For those who don't belive the 92-93 isnt 205hp 260tq ssesc93 General GM Chat 27 07-30-2004 12:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:20 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.