For gods sakes help me! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-13-2009, 10:30 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
MrWeary is on a distinguished road
Angry For gods sakes help me!

My 1999 Bonneville vin 3.8-K starts easily, at the first time, when engine is cold. Or After Sitting A Few Hours!
Or a few times after I try right away.
But after engine is hot (200 degree-midline), it gets difficult to start (hard start)
Or Barely starts - Ruff - Shakeing Ect. . If I push the gas pedal several times.Sometimes I can Get it to Run.
Once it starts, it runs smoothly! Great !
Thing runs great after ( if ) i get it started .. Let it sit for a hour or two starts fine.
I have replaced every sensor .. spark plugs / wires And ALL the fuel injectors!
And No Its Not the fuel Pressure regulator! I Replaced that too!
No engine/service lights.
Any idea? For gods sakes help me ! LOL Its Driving Me Crazy !
[


Last edited by MrWeary; 03-13-2009 at 10:34 PM.
MrWeary is offline   Reply With Quote
Old 03-13-2009, 10:38 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Have you tried changing the IAT Intake Air Temp Sensor?
Danthurs is offline   Reply With Quote
Old 03-13-2009, 10:52 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
MrWeary is on a distinguished road
Default

Quote:
Originally Posted by Danthurs View Post
Have you tried changing the IAT Intake Air Temp Sensor?
Ok Thats One I Havent Done FFS lol

Dono How that would make it hard starting when engine is hot.
Cause the air temp here in minnesota is 35 Right now :/

Last edited by MrWeary; 03-13-2009 at 10:57 PM.
MrWeary is offline   Reply With Quote
Old 03-13-2009, 10:58 PM   #4
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

It tels the PCM what the air temp is and that helps determine the AFR, if it'* wrong the engine will be lean or rich.
Danthurs is offline   Reply With Quote
Old 03-13-2009, 11:43 PM   #5
Junior Member
Thread Starter
 
Join Date: Mar 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
MrWeary is on a distinguished road
Default

Quote:
Originally Posted by Danthurs View Post
It tels the PCM what the air temp is and that helps determine the AFR, if it'* wrong the engine will be lean or rich.
OMG I Am SOOOO PISSED OFF!

I Search Everywhere on the net NOT ONE PERSON SAID THAT SENSOR!


Check The Fuel Pump Check The MASS air flow Check the Presure Reg.
Check This Try That .. Replace This Ohhh its Got to be a leakey Fuel Injector!

Replaced 1,000,000,00 $ Of Parts .. Oh It Still Does It.

No No you say try this: air temp sensor - Air Charge Sensor
So I Unplug The dam Thing .. and HUH ? Starts right Up. When Hot!

Air Charge Sensor
Part Number: SU176
Weight: 0.05 lbs.
Pricing:
$11.99

11$ ??? OMG I wana kill myself!
MrWeary is offline   Reply With Quote
Old 03-13-2009, 11:49 PM   #6
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

I hate replacing sensors. Test them first. Check the testing area of the tech info.
Danthurs is offline   Reply With Quote
Old 03-14-2009, 12:15 AM   #7
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

MRWEARY;

You obviously needed to come here first!

Chasing sensors down can be a bear and very frustrating, especially when they aren't throwing a code. Sounds like you got it fixed though courtesy of Dan.

Please add your year and trim of your vehicle to your signature line. That way when you start asking questions in other areas of the forum, we all have a better idea on how to assist you. Click on "Quick Links" above, go down to "User Control Panel" and then click on "Edit your Signature" It'* pretty straight forward from there.
Purplehazeir is offline   Reply With Quote
Old 03-14-2009, 01:03 AM   #8
Junior Member
Thread Starter
 
Join Date: Mar 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
MrWeary is on a distinguished road
Default

Quote:
Originally Posted by Purplehazeir View Post
MRWEARY;

You obviously needed to come here first!

Chasing sensors down can be a bear and very frustrating, especially when they aren't throwing a code. Sounds like you got it fixed though courtesy of Dan.

Please add your year and trim of your vehicle to your signature line. That way when you start asking questions in other areas of the forum, we all have a better idea on how to assist you. Click on "Quick Links" above, go down to "User Control Panel" and then click on "Edit your Signature" It'* pretty straight forward from there.
99 3.8l sse

Well .. It Kinda Fixed it .. Just went out to start it .. been sitting there for 45 minutes.
Same Old thing .. starts but runs like its way to rich .. studders.. have to push the gas pedel several times to make it run. untill i can get it cleared.. then runs fine.

( shakes Head .. ) Ijust dont get it.. is there something elese that would tell the computer
to run it rich ? when hot ?
MrWeary is offline   Reply With Quote
Old 03-14-2009, 01:08 AM   #9
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

The IAT, MAF, and O2 sensor all work together. A easy MAF test is to simply unplug it. If the engine runs better, you may have found the problem. Just keep your foot off the heavy gas. The O2 sensor should be replaced after 60k or so. Try testing your TPS https://www.gmforum.com/t279319/ It might cause some problems.
Danthurs is offline   Reply With Quote
Old 03-14-2009, 01:09 AM   #10
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

You can try taking a look here, it might help.

https://www.gmforum.com/t279317/
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
the bonneville gods communicating with me yesterday 1993 SLE General GM Chat 9 07-30-2006 10:25 PM
are gods telling me something????? 1993 SLE General GM Chat 13 12-17-2005 11:18 AM
2nd NEBF Pics - Mods, Gods, and Bods - 56K - no way singscountry1967 Your Ride: GM Pictures & Videos 23 10-27-2005 09:19 PM
Nissan 240's, Gods car? ComfyCar Lounge 18 09-21-2005 05:31 PM
Winter Gods want Bonnevilles DEAD! Allmachtige Lounge 10 12-09-2002 08:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:13 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.