erratic idle leading to stalls - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-29-2009, 06:26 AM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
walt0551 is on a distinguished road
Default erratic idle leading to stalls

I have a 1994 bonneville se with 88,000 miles. I bought the car 2 weeks ago. The engine would miss a few times and stall. This would happen at all speeds, but always starts right up. After reading some of the other posts on this site, I decided to replaced the Crank Position Sensor . After replacing the CPS I took the car for a long drive and the car ran perfect not a single miss or stall. The next day I started the car and it ran for about 5 seconds then shut off. Restarted it and it is missing and the idle is very erractic( 100-900 RPM fluctuates). The car will not run for more than a minute or two before it shuts off. My battery cables are tight & free of corrosion. Any help would be greatly appreciated.
walt0551 is offline   Reply With Quote
Old 08-29-2009, 07:12 AM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Check it over good for vacuum leaks. How old are the spark plug wires? Have you changed the plugs?
Danthurs is offline   Reply With Quote
Old 09-05-2009, 03:27 AM   #3
Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
walt0551 is on a distinguished road
Default

Dan, Just had the car checked for vacuum leaks. No leaks. Replaced Spark plug cables and plugs. Still stalls. Anything else I should be looking at? Thanks.
walt0551 is offline   Reply With Quote
Old 09-05-2009, 08:06 AM   #4
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Do you smell gas in the exhaust? Just had a car here with rough idle and it was a broke valve spring. Check over coils real good, plug wires, pull all the plugs and inspect them close. Are any of them black?
Danthurs is offline   Reply With Quote
Old 09-06-2009, 03:03 AM   #5
Junior Member
Thread Starter
 
Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
walt0551 is on a distinguished road
Default

Dan the spark plugs and spark plug wires in the cars are 3 days old. The old plugs that I pulled out were in perfect condition but decided to replace them since I already had them out. Gap was 060. I removed the coils and the ICM as you suggested, checked for corrosion and loose or damaged wires. Cleaned and reassembled. Checked ground under alternator and under drivers side door. Both are corrosion free. Later in the day I drove the car 4 miles to buy a fuel pressure gauge, car stalled 6 times at speeds under 40 mph. Over 40 mph the car will loose engine power, rpm'* drop to 0 for a second or so them jump back up to 3000 then settle at 1200 rpm'*, but the car will not turn off over 40 mph. Drove back home not a single stall at any speed. Then drove 15 miles at speeds of 0 to 55 mph with no problems. The car is idling a little rough but has stops stalling. Rpm'* stable at 700. No fuel smell in exhaust. No SES light. Will check fuel pressure and amps at coils and replace fuel filter in the next day or so. Will keep you posted on the results. Thanks for the help.
walt0551 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Erratic idle vektron75 1992-1999 1 01-31-2012 04:04 PM
96 SSE stumbling, erratic idle psherman Pontiac 9 05-31-2010 10:49 PM
Erratic idle bad mpg GaryH 1987-1991 1 01-03-2009 02:11 PM
95 SE erratic idle, hard starting, stalls, no Check engine rockken_cosworth 1992-1999 14 08-22-2007 10:57 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.