Engine Prob. Please Help!!! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-22-2005, 07:22 PM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2005
Location: Upstate NY
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
kokid426 is on a distinguished road
Default Engine Prob. Please Help!!!

i have a 97 SSE and just had my tranny flushed today that took care of a lugging problem, but i also have a problem with the engine. they said i may just need a tune up, but i cant afford what they were asking right now so me n my dad want to work on it on our own for now. this only seems to happen when im driving under 40 and only at certain times, but the engine begins to shake and the engine doesnt want to rev above 3000 rpm. also, the check engine light starts to flash whenever this happens. the guys at the shop said i might not be firing on a few cylinders due to old spark plugs that need to be replaced, but i dont know (as i dont know much about what im doing under the hood). so i have 2 questions, does replacing the spark plugs sound like the solution to the problem, and what are the best ones to buy if this is the case? thanks in advance for any help!!!
kokid426 is offline   Reply With Quote
Old 12-22-2005, 07:34 PM   #2
Member
Posts like a V-Tak
 
Join Date: Feb 2003
Location: st. louis
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
techy is on a distinguished road
Default

Take it to an Auto Zone or somewhere for a free code check. Doesn't sound like plugs to me, since it'* at lower RPMs and a sometimes thing.
techy is offline   Reply With Quote
Old 12-22-2005, 08:30 PM   #3
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Yes GO to Autozone or Advance, to get the codes scanned..they do it for free......and please write the code down.....

if we dont know the code we cant help ya
1993 SLE is offline   Reply With Quote
Old 12-22-2005, 08:46 PM   #4
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

If you're on a tight budget just take the plugs out & examine them. White to light brown is good, dark brown to black is bad. If any are bad let us know which cylinders they came from.

Do you know how long its been since the fuel filter was changed?
How many miles on the car?
Technical Ted is offline   Reply With Quote
Old 12-23-2005, 11:28 AM   #5
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default codes

yes get the codes, its the logical start to the problem.
SSEBONNE4EVA is offline   Reply With Quote
Old 12-23-2005, 11:35 AM   #6
Senior Member
True Car Nut
 
Join Date: Aug 2004
Location: The South
Posts: 3,281
Thanks: 0
Thanked 0 Times in 0 Posts
Lowrider0308 is on a distinguished road
Default

a flashing check engine light is a misfire code right? (even if this is right, get it scanned)
Lowrider0308 is offline   Reply With Quote
Old 12-23-2005, 12:21 PM   #7
Senior Member
Certified Car Nut
 
Join Date: Jul 2003
Location: Robbinsdale, MN
Posts: 15,408
Thanks: 0
Thanked 0 Times in 0 Posts
MOS95B is on a distinguished road
Default

I would definitely invest in a set of plugs and wires while you're at the parts store checking for stored codes....
MOS95B is offline   Reply With Quote
Old 12-23-2005, 12:42 PM   #8
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

How about let'* take a GOOD look at the coolant and oil? Is the oil milky in any way? Anything other than normal? Is your coolant level dropping?
willwren is offline   Reply With Quote
Old 12-23-2005, 01:32 PM   #9
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

Willwren and Mos Have very good points here...

Plugs and wires can and will cause a nasty miss if there is a problem... And for the Waste spark method to work correctly the Plugs and wires have to be good...

The Flashing SES light means that there is a random multiple missfire.... This will usually be most noticeable under load say at 40 Mph with the TCC applied...

My bet is plugs and wires, But do take the car down to Autozone, Or Advanced, both of them can scan codes for you...

Look to see if you have a Code P0300 or a P0301-P0306...

The 300 should be something along the lines of Multiple missfires detected iirc ... 301-306 will point out the individual cylinders, and may give you a direction to go in..

Have them read the codes, get them printed or written down, have them erase the codes and see if they later return or the SES comes back on again...

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 12-23-2005, 08:23 PM   #10
Junior Member
Thread Starter
 
Join Date: Jul 2005
Location: Upstate NY
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
kokid426 is on a distinguished road
Default new sparks today

last night i took my car down to advance auto parts, grabbed a set of new spark plugs, and had them read the code. it turned out to be multiple misfires. so today i put in new spark plugs today and the car isnt kicking anymore, but that was only after a very short ride. we started the engine up and looked at it in the dark, and wire #3 was sparking so we cleaned that up and that stopped. nothing seems wrong so far but id still like to take it for a longer ride and see how things go. the check engine light is still on but nothing seems wrong as far as i know. my guess is that i just need to give it some time or unhook the battery for a while. for now everythings good, but if anything goes haywire i know where to come first. thanks all!!!
kokid426 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
weird brake/engine prob qball 1987-1991 2 09-24-2008 09:16 PM
Check Engine light came on!!! Think it's a UIM prob... HELP! 99SilverSE 1992-1999 5 10-14-2007 04:40 PM
weird prob need help fast please the kid 1987-1991 5 06-28-2007 03:00 AM
Gas Prices are high, maybe this will help solve prob..... ssesc93 Lounge 5 04-09-2004 05:02 AM
any 1 have this prob...can you help? jcbb602 1992-1999 6 05-05-2003 01:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:21 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.