EGR Valve (Loss in Performance?) - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-18-2008, 02:19 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Oct 2007
Location: Fond du Lac, WI
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
sharpshooter3578 is on a distinguished road
Default EGR Valve (Loss in Performance?)

I have recently developed yet another problem with my 1994 SSEi!!! When I accelerate hard and get to around 50 mph when the transmission shifts again I get a decrease in engine power and feel and sound as if my engine is missing but really fast.

I pulled my codes the other day and I got an EGR Fault code. So I cleaned the EGR and the port that is mounts to and I am still having the same problem... I would go ahead and replace the EGR but they run about 150 bucks... To me it feels as if the MAF sensor is shot as I have experienced this in other vehicles but I did not pull any codes for the MAF. I am confused and would like to fix the problem with one shot! I don't want to have to buy the MAF and EGR... OUCH!

Any help is appreciated. Thanks.

-----------------------------------------------------------------------------------------------------
1994 SSEi, NGK TR 55'*, JL subwoofer, CAI, Hyper yellow headlights, rebuilt transmission
sharpshooter3578 is offline   Reply With Quote
Old 02-18-2008, 11:16 AM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

I would go after the current codes first. If that doesn't fix the other symptoms, but clears the code, we'll go in deeper.
willwren is offline   Reply With Quote
Old 02-21-2008, 06:36 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Oct 2007
Location: Fond du Lac, WI
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
sharpshooter3578 is on a distinguished road
Default

Would an unusually high idle also be a symptom of my EGR going bad? I cleaned it the other day and it didn't seem to help. Now today when I started it up it idled at around 1500 rpms and gradually climbed to around 3000. So I shut the car off and restarted it like I always do when it does this and then it began to stutter and chug. After restarting it the second time it finally started to act normal.

Is all of this possibly cause of my EGR? That is the only code that I am pulling at this point in time. It was an EGR Fault warning. Got any ideas?
Thanks, Josh

The other symptoms of surging and loss of power are still occuring at WOT as I said at the begining of this thread. Any help is appreciated... Thanks again.

---------------------------------------------------------------------------------------------------
1994 SSEi, CAI, TR 55'*, JL subwoofer, rebuilt trans, 184,000
sharpshooter3578 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Tire air loss - valve stem, TPMS, prank? scottydl Buick 2 04-07-2015 02:17 PM
Purge valve solenoid or egr valve? SEXI SADI GMC/Chevrolet Truck/SUV 5 03-28-2012 12:18 PM
Loss of accelleration and egr code, 97 Bonn 97BonnSSE 1992-1999 6 05-20-2006 10:43 PM
EGR low flow. Replaced EGR, still getting code 1997_LeSabre 1992-1999 8 04-20-2005 10:06 AM
Performance loss with 180 degree thermostat?? sellncars Performance, Brainstorming & Tuning 26 06-24-2004 03:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:30 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.