EGR gone bad - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-25-2009, 07:07 PM   #21
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2009
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
boa12 is on a distinguished road
Default

btw, that hose size is 7/32".

I went to change back my previous egr valve & can't get that plug clip that goes into the replacement egr on the car to come out. it'* a clip on the electrical plug that snaps into a plastic bracket built onto the egr. any special tool/technique to get that thing off? seems you have to push in the clip to get it past the bracket, but I can't get it out.

I noticed I broke the plastic bracket (clip holder) off my original egr when I wedged it out with a flathead screwdriver before. don't know if I should even put that back on now sice it won't clip on. is that clip really necessary on that plug into the egr valve?
boa12 is offline   Reply With Quote
Old 06-25-2009, 07:13 PM   #22
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

It should stick fine without the clip.
Danthurs is offline   Reply With Quote
Old 06-25-2009, 08:58 PM   #23
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2009
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
boa12 is on a distinguished road
Default

Quote:
Originally Posted by Danthurs View Post
It should stick fine without the clip.
ya, it does. no need even for super glue. & I got the other one off without breaking the clip
bracket - finally, pretty tricky for me.

anybody know what that other black tube next to the one we were talkin' about earlier runs to & from? that hose connector down by the other tube connector that broke & hosed is broke too. it'* whistling at that rubber connector at the silverish metal cannister (in attached pic in my previous post). hopefully when that'* fixed it fixes the engine running trouble.

Last edited by boa12; 06-25-2009 at 09:07 PM. Reason: add pic
boa12 is offline   Reply With Quote
Old 06-26-2009, 12:40 PM   #24
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2009
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
boa12 is on a distinguished road
Default

I'll start a new thread on the above inquiry, as it doesn't relate to the EGR anymore.
boa12 is offline   Reply With Quote
Old 07-18-2009, 04:03 PM   #25
Junior Member
Posts like a V-Tak
 
Join Date: Apr 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
lildony is on a distinguished road
Default

I have the same symptoms as you on my 97 so was it the egr valve you needed to replace or you had
a vaccum leak cause I know I have a leak I'm trying to replace that whole lune same 1 u had a picture of
lildony is offline   Reply With Quote
Old 07-18-2009, 04:40 PM   #26
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2009
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
boa12 is on a distinguished road
Default

Quote:
Originally Posted by lildony View Post
I have the same symptoms as you on my 97 so was it the egr valve you needed to replace or you had
a vaccum leak cause I know I have a leak I'm trying to replace that whole lune same 1 u had a picture of
you have the gassy smell & rough idle? my egr was fine - I went & put the original egr valve back on & replaced all the vacuum hose pieces on those tubes in the pics.
no more gassy smell & the engine is pretty much running smooth now.

what'* a lune?
boa12 is offline   Reply With Quote
Old 07-19-2009, 12:40 PM   #27
Junior Member
Posts like a V-Tak
 
Join Date: Apr 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
lildony is on a distinguished road
Default

Sorry I put lune I ment line lol ...but yea I smell gas my car when idling is very rough as soon as I turn it on it shakes n when I gas it it stops ...can I just replace that whole vaccum line ... N how do I check if the egr is good or bad
lildony is offline   Reply With Quote
Old 07-19-2009, 01:02 PM   #28
Junior Member
Posts like a V-Tak
 
Join Date: Apr 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
lildony is on a distinguished road
Default

N were'd u get the hose pieces
lildony is offline   Reply With Quote
Old 07-19-2009, 03:58 PM   #29
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2009
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
boa12 is on a distinguished road
Default

I found a used EGR on ebay - the guy sold it to me on trial basis fortunately, but I'd check the hose pieces for vacuum leaks 1st before messing with the EGR. Are you getting any "Service Engine Soon" lights?

You can get the hose at any auto parts store. I used 7/32" & 1/4" hose depending which fits.

The other guys here know best what to do. I'm just a novice - at best.
boa12 is offline   Reply With Quote
Old 07-19-2009, 06:51 PM   #30
Junior Member
Posts like a V-Tak
 
Join Date: Apr 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
lildony is on a distinguished road
Default

Yea I get ses
lildony is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
Reuters gone mad! Passports ablaze! Quotes gone wrong! radomirthegreat Lounge 2 03-24-2008 08:05 AM
Here Yesterday....Gone Today - Pontiac Dealership is GONE!!! Ol' Timer Lounge 5 04-06-2007 05:48 PM
EGR low flow. Replaced EGR, still getting code 1997_LeSabre 1992-1999 8 04-20-2005 10:06 AM
BAD one liners. Bad, really really bad, but still funny. BonnieBrougham Lounge 3 12-16-2004 06:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:01 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.