Crank Sensor Cleaning, now something is squealing - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-08-2006, 12:22 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2006
Location: Charlottesville, VA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Supercharged! is on a distinguished road
Default Crank Sensor Cleaning, now something is squealing

So I think I've determined the cause of my cam/crank circuit error. The crank sensor is loose to the touch. I can jiggle it freely with my finger.

I was able to disconnect the wiring harness without taking anything apart, so I decided to clean it out with some brake cleaner to see what happens. Well, I think i've made the problem worse the idle is jumpier and the car is missing more frequently. I think I blasted away some of the gunk that was providing some stability to the sensor. Now that it jiggles more freely, the problem has gotten worse. At least I've found the problem!

Anyhow, the brake cleaner got into something and has caused a pretty annoying whine. I tried some belt dressing, but that didn't help. Therefore, I think it coming from something other than the belt.

When I take off the belt and harmonic balancer to replace the sensor, what should i use to clean/lube the mechanical parts?

Also, do I really need an impact wrench to get the bolt off the harmonic balancer?

Thanks!
Supercharged! is offline   Reply With Quote
Old 12-08-2006, 12:23 PM   #2
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2006
Location: Charlottesville, VA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Supercharged! is on a distinguished road
Default

oops, I meant to add this to this thread http://www.bonnevilleclub.com/forum/...ic.php?t=67277
Supercharged! is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
A Bad TPS sensor or something else (Throttle position sensor) DeathDealer General GM Chat 17 03-27-2017 10:30 PM
2001 Chevy Express van with crank sensor / cam sensor correlation problems PStan Chevrolet 6 05-08-2014 05:45 AM
changed crank sensor now no tach 1989_IROC-Z Pontiac 11 07-29-2012 11:27 PM
Relation of cam sensor to crank sensor. 57lxi 1992-1999 4 07-29-2010 02:27 PM
Replaced Crank Sensor, now I am blowing Fuel Pump Fuses!!! jaye22 1992-1999 2 05-22-2006 06:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.