Code PO705 Trans range sensor malfunction - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-17-2005, 07:08 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
kennyz is on a distinguished road
Default Code PO705 Trans range sensor malfunction

Hi again, guys. I`m still chasing that low RPM surge on my 94 SE that I inquired about last week but now I have a trouble code, also. Can anyone explain PO705 Transmission Range Sensor Malfunction to me and what i should be looking for and can do about it? Also, could there be a relation between this and my low RPM surge even though I can make it surge in Park and Neutral?
kennyz is offline   Reply With Quote
Old 12-17-2005, 07:40 PM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

DTC P0705 Trans Range Switch Circuit

I'm assuming this is the PRNDL switch in the shifter assembly. It would cause no change in perceptible performance, but might at some point prevent starting in Park. A neutral start would diagnose it as bad.

Your surge is air/fuel related. Try a good throttle body cleaning.
willwren is offline   Reply With Quote
Old 12-17-2005, 08:40 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
kennyz is on a distinguished road
Default

Thanks, willwren. Throttlebody has been cleaned with no affect to surge.
kennyz is offline   Reply With Quote
Old 12-17-2005, 08:46 PM   #4
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Can you put '94 SE' in your sig? Or '94 SLE' if you have the H4U RPO code on your spare tire cover?

Is it a surge in N or just a drive gear? Park? Reverse? Temp related?
willwren is offline   Reply With Quote
Old 12-17-2005, 09:33 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
kennyz is on a distinguished road
Default

Surge is in all gears and does not seem to be temp related. It feels much smoother above 1500 RPMs and appears more prominent at lighter throttle pressure.
kennyz is offline   Reply With Quote
Old 12-17-2005, 09:35 PM   #6
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

If it'* in idle and park also (uneven idle, seems to be hunting), your IAC is suspect above all else. I'd say MAF is second.
willwren is offline   Reply With Quote
Old 12-18-2005, 06:31 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
kennyz is on a distinguished road
Default

Willwren, the car at idle is fairly smooth. The surge occurs as you bring the idle up and is in the 1400-1600 RPM range, Does this still point towards the IAC motor?
kennyz is offline   Reply With Quote
Old 12-18-2005, 07:28 PM   #8
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

I'm assuming in park or Neutral as well, or not? Please be VERY specific. It matters a bunch.
willwren is offline   Reply With Quote
Old 12-19-2005, 11:17 AM   #9
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Have you checked for vacuum leaks and when was the last time the plugs/wires were done?
BillBoost37 is offline   Reply With Quote
Old 12-19-2005, 07:18 PM   #10
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
kennyz is on a distinguished road
Default

No vacuum leaks, new plugs and wires. Willwren, it happens in both neutral and park as well as in any gear. Today it got worse. It shut off on three different occassions as I was slowing for a light. Started right up again but the surge has gotten worse and at a lower (1000) RPM. Also, can start to feel it at speed, now. It still idles OK though. Still no check engine light or codes either.
kennyz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ride Height Sensor Malfunction?? bigbonnieboi 1992-1999 2 08-28-2012 09:31 AM
Tps sensor out of range? teejay37 1992-1999 1 02-08-2011 09:48 PM
1991 SSE - code 28 code 39 code 42 - losing sleep labonnita 1987-1991 9 12-26-2009 10:58 PM
Code 57 - Boost Control Malfunction..... UGH. Bonneville92V688 Forced Induction 6 12-19-2007 09:11 AM
Driver's Side Window Malfunction 96AZSSEi 1992-1999 12 03-03-2003 11:48 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:57 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.