Climate Control Mode Switcher - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-03-2006, 03:36 PM   #1
Xaa
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2005
Location: Charlotte, NC
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Xaa is on a distinguished road
Default Climate Control Mode Switcher

Hi,

Recently I turned the **** on my 94 SE that changes the function from defrost to blowing through the vents to AC etc. When I did that the **** stripped. Something else must have happened as well.

Now, if I use the **** from the airmix controller (hot/cold) in place of the stripped ****, the pin turns but it will not switch from it'* current position (defrost). Tthat would be a great place for it to be if I could only have one, but the problem is that I can't turn it to any of the AC settings to get the compressor to come on and cool off the car.

I think the airmix actuator is located by the heater core, but I don't have a clue of what device is controlling the switching of activites or where it'* located.

Any help is appreciated.

Xaa
Xaa is offline   Reply With Quote
Old 05-03-2006, 05:25 PM   #2
Senior Member
True Car Nut
 
Join Date: May 2005
Location: _Phoenix, AZ_ _WCBF '05, '06, '07 Survivor_ ____NEBF '07 Remnant___
Posts: 3,448
Thanks: 0
Thanked 0 Times in 0 Posts
Echo SSEI is on a distinguished road
Default

The switch (and ****) to control air distribution controls both vacuum and electrical functions for air delivery and to signal the compressor. My particular switch in my '94 wouldn't rotate and was locked in a non-ac position. I replaced the whole unit with one from e-bay/ The switch had gone bad, and the replacement worked fine.

To begin with, I suggest you remove your lower dash panel to remove the climate control unit. The panel is held on by clips. Carefully pry the panel all the way around until the panel clips are released. Remove the climate control unit and inspect the clear connector with all the little color vacuum lines. Look for a collapsed line. If you find one, you may be able to splice in a new line to repair.

Also, check any electrical connections.

You may need a new switch, but thought that some of this info would help.
Echo SSEI is offline   Reply With Quote
Old 05-03-2006, 06:06 PM   #3
Xaa
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2005
Location: Charlotte, NC
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Xaa is on a distinguished road
Default

Thanks, I'll look for those things, it'* getting warm here in charlotte. What is that assembly called if I needed to search for a used one? Climate Control Unit?
Xaa is offline   Reply With Quote
Old 05-03-2006, 06:16 PM   #4
Senior Member
True Car Nut
 
Join Date: May 2005
Location: _Phoenix, AZ_ _WCBF '05, '06, '07 Survivor_ ____NEBF '07 Remnant___
Posts: 3,448
Thanks: 0
Thanked 0 Times in 0 Posts
Echo SSEI is on a distinguished road
Default

Called several different things.....I'll need to look in the book to find out the exact name. Here is an ebay one (but says for 96-99). I got mine from a 95 for about 19.99 plus 5 shipping. Can't remember if they are different for different years or interchangeable, though.

http://cgi.ebay.com/ebaymotors/96-97...QQcmdZViewItem
Echo SSEI is offline   Reply With Quote
Old 05-03-2006, 06:27 PM   #5
Xaa
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2005
Location: Charlotte, NC
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Xaa is on a distinguished road
Default

Think I found one for me.

http://cgi.ebay.com/ebaymotors/Ponti...ayphotohosting

So if I understand what you're saying to me, my problem is likely one that is electrical vs one that is mechanical like an arm moving a door? Right?

i'll investigate, solve and post back with either more questions or results. Thanks!
Xaa is offline   Reply With Quote
Old 05-03-2006, 06:51 PM   #6
Senior Member
True Car Nut
 
Join Date: May 2005
Location: _Phoenix, AZ_ _WCBF '05, '06, '07 Survivor_ ____NEBF '07 Remnant___
Posts: 3,448
Thanks: 0
Thanked 0 Times in 0 Posts
Echo SSEI is on a distinguished road
Default

Quote:
Originally Posted by Xaa
Think I found one for me.

http://cgi.ebay.com/ebaymotors/Ponti...ayphotohosting

So if I understand what you're saying to me, my problem is likely one that is electrical vs one that is mechanical like an arm moving a door? Right?

i'll investigate, solve and post back with either more questions or results. Thanks!
That would be the one you would want.

Honestly, the controller is only a POSSIBLE solution. There very well could be a different problem like loss of vacuum (since the air blend door and outlets are controled though the vacuum tubes or a door could be stuck or binding. But since you said the "pin" turns but no change in the climate position is noticed, I was offering my experience with the manual ****. Remember, though, my "pin" simply stopped turning and was jammed.

I will do a little more research to see what else I can find and in the meantime, some others may be able to chime in and give their opinion. You should check the back of your climate control unit for the clear connector with vac lines to first see if any are collapsed or clogged lines as well as checking the electrical connections.
Echo SSEI is offline   Reply With Quote
Old 05-03-2006, 07:48 PM   #7
Xaa
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2005
Location: Charlotte, NC
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Xaa is on a distinguished road
Default

Thanks, I appreciate everything that you've done, I know you can't know from there.

I messed with it a bit on the way home and it appears that the switch might be working. I turned it and still nothing to the floor or vents and no compressor turn on, but when I went all the way to off, it went off.

I'll investigate some more. Thanks

Xaa
Xaa is offline   Reply With Quote
Old 05-08-2006, 02:46 PM   #8
Xaa
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2005
Location: Charlotte, NC
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Xaa is on a distinguished road
Default

Just to update. Based on this thread and another, I learned a lot about the system. I inspected everything and found a vacuum hose off in the enging compartment. Hooked it back up and all is well. I lucked out.

Thanks for all the help.
Xaa is offline   Reply With Quote
Old 05-08-2006, 02:50 PM   #9
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

On the vacuum accumulator on the firewall next to the master cylinder? The fitting underneath?

Yup.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Muffler to Straight Pipes switcher thingy GoldenBullet General GM Chat 19 11-10-2006 11:36 AM
2001 SSEi Automatic Climate Control - Blower Control Module andereck 2000-2005 3 08-10-2006 11:58 PM
Mode 6 Diagnostic Codes mremer General GM Chat 9 11-07-2003 10:37 AM
Night vision Stealth mode.. Drifter420 Performance, Brainstorming & Tuning 33 07-22-2003 07:34 PM
Performance shift mode research update willwren Performance, Brainstorming & Tuning 0 10-09-2002 04:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:02 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.