Chugs while Accelerating, 95 SSEi - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-30-2009, 11:13 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: May 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
stereoxide is on a distinguished road
Default Chugs while Accelerating, 95 SSEi

I have a 1995 SSEi and it chugs (shakes/hesitates) when accelerating past 40(-ish) mph. Started about a couple of days after I replaced my alternator (refurb). It'* not a continuous shaking. Shakes only whenever I press on the gas pedal and accelerates.

It also has a problem with accelerating from stop, like its hesitating to accelerate from stop. It goes, but its slow and you can hear a noise like the engine is getting overworked I guess. I'm thinking it might be connected to the previous problem.

Anyone know what might be wrong?

Things I've done that I thought might be the problem:
-Replaced the fuel filter
-Replaced the PCV valve
-Checked air filter (looks clean so I didn't replace it)

Last edited by stereoxide; 07-30-2009 at 11:16 PM.
stereoxide is offline   Reply With Quote
Old 07-31-2009, 09:47 AM   #2
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Had that on my car. Started and ran fine. Sputtered and hesitated when I leaned on it a little, such as accelerating on an entrance ramp. Turned out to be a cracked ceramic insulator on the #4 spark plug. It would only arc under load.

Check your plugs and wires.
2kg4u is offline   Reply With Quote
Old 08-02-2009, 02:19 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: May 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
stereoxide is on a distinguished road
Default

Quote:
Originally Posted by 2kg4u View Post
Had that on my car. Started and ran fine. Sputtered and hesitated when I leaned on it a little, such as accelerating on an entrance ramp. Turned out to be a cracked ceramic insulator on the #4 spark plug. It would only arc under load.

Check your plugs and wires.
Replaced the spark plugs and wires. Looks like its stable now. Don't know why I didn't think of that earlier. Thanks!
stereoxide is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Hesitation While Accelerating 2k2cse Buick 14 09-27-2011 04:20 PM
slight misfire/stutter in o.d. while lightly accelerating ak1920 2000-2005 33 02-17-2011 09:11 PM
Thud while accelerating ggenovez 1992-1999 5 06-14-2009 12:30 AM
Small surge/hesitation while accelerating Boreas 1992-1999 2 06-06-2006 08:13 PM
friends bonnie chugs... White Lightning 1992-1999 12 08-25-2003 05:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:58 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.