Check engine so0n.... - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-01-2002, 03:11 AM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Sep 2002
Location: Louisiana
Posts: 230
Thanks: 0
Thanked 0 Times in 0 Posts
TiMSmo0th is on a distinguished road
Default Check engine so0n....

that damn light came on today!!!
my code reader thingy tells me its a code 41
says it could be a few problems:
-CAM sensor failure
-Cylinder select error
-Tach input error - no reference pulses during engine run
-EST (electronic spark timing) circut open or shorted to ground during engine run
-DIS (Direct ignition system) fault bypass circut open or shorted '" " "" ''
-Ignition system fault - loss of 1X Reference Pulse signal

but the car runs the same as it always has, which makes me think it is mabey a sensor gone bad, but if anyone can help me out, it is appreciated.
TiMSmo0th is offline   Reply With Quote
Old 12-02-2002, 12:03 AM   #2
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

My book says "Cam Sensor Circuit." I've never replaced one of these before, but I'm sure someone else has.
fuddyduddy121 is offline   Reply With Quote
Old 12-02-2002, 02:12 AM   #3
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Sep 2002
Location: Louisiana
Posts: 230
Thanks: 0
Thanked 0 Times in 0 Posts
TiMSmo0th is on a distinguished road
Default

yea I checked it out today and my CAM connector piece is all melted. Ill try and post the pix. If anyone can give me some info on how to change this out, it would be appreciated.
TiMSmo0th is offline   Reply With Quote
Old 12-02-2002, 10:21 AM   #4
Guest
 
Posts: n/a
Default

Your going to have to go get another Cam Sensor & plug in Connector too. The best bet is the GM Dealer as they will have the listing for the Cam sensor & it'* Connector too.
  Reply With Quote
Old 12-02-2002, 02:21 PM   #5
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Sep 2002
Location: Louisiana
Posts: 230
Thanks: 0
Thanked 0 Times in 0 Posts
TiMSmo0th is on a distinguished road
Default

hey Deathrat, can you give me the part #'* for the CA sensor and plug?
And how hard will this be to replace GMMAN?
TiMSmo0th is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
check engine flashing, OBD reports heavy misfiring but engine sounded OK? cadimus Pontiac 3 08-24-2013 11:55 PM
Phantom Check Engine Light/Rough Engine/Coolant Temp. Gauge Whacky RWW2003 1992-1999 10 11-13-2009 08:00 AM
Engine miss, check engine light on - NO code mdrose64 1992-1999 12 07-16-2007 12:43 PM
The "Check engine" engine SignOfZeta General GM Chat 14 04-11-2005 05:08 PM
Service Engine Soon vs. Check Engine vital49 1992-1999 6 03-22-2004 05:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.