car still getting hot, new thermo, water pump replcd - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-04-2006, 05:00 PM   #11
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Another thing to keep in mind.. the gauge may not be very accurate for temp. You may want to bring it in to the mechanic and get a good idea where the temps are relative to the gauge.
BillBoost37 is offline   Reply With Quote
Old 10-04-2006, 05:16 PM   #12
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2006
Location: Seattle, WA
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
base1001 is on a distinguished road
Default

base1001 is offline   Reply With Quote
Old 10-04-2006, 05:19 PM   #13
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2006
Location: Seattle, WA
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
base1001 is on a distinguished road
Default

it gets to the next bar when driving for a while, never the red though. still havent heard a fan.

i tried pulling out the ac fuses and reconnecting. nothing. how do i know if it needs a recharge or other fix w/o spending too much cash?
base1001 is offline   Reply With Quote
Old 10-04-2006, 05:23 PM   #14
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2006
Location: Seattle, WA
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
base1001 is on a distinguished road
Default

Quote:
Originally Posted by willwren


Your wire colors may differ for a 95, but you should be able to see where the relays are in this pic.
what i did was disconnect the plastic fasteners, then pulled apart a few times and snapped them back together. is this what i needed to do? i also pulled a majority of the fuses out and put back in.
base1001 is offline   Reply With Quote
Old 10-04-2006, 05:37 PM   #15
Senior Member
True Car Nut
 
Join Date: Jul 2006
Location: Granville, Ohio ~NEBF '07 Survivor~
Posts: 5,001
Thanks: 0
Thanked 0 Times in 0 Posts
petraman is on a distinguished road
Default

I have the same issue; I was told that the gauges were off and that my car is running fine. Also, have you had any issues with your oil pressure gauge?
petraman is offline   Reply With Quote
Old 10-04-2006, 05:45 PM   #16
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Base, do the fans come on when you turn your AC to Auto?
willwren is offline   Reply With Quote
Old 10-04-2006, 06:09 PM   #17
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2006
Location: Seattle, WA
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
base1001 is on a distinguished road
Default

the electronic climate control always show a/c on the display.

today is around 65F outside so kindof hard to test the cool air. i will try
base1001 is offline   Reply With Quote
Old 10-04-2006, 06:11 PM   #18
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2006
Location: Seattle, WA
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
base1001 is on a distinguished road
Default

yes, it does come on, i just checked. and after turning the ECC off the fan goes off as well.
base1001 is offline   Reply With Quote
Old 10-04-2006, 06:13 PM   #19
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Replace one relay with another relay farther to the left. Label them first so you know which was which. One will be your horn (disconnect them one at a time and try the horn). That'* the best relay to use for troubleshooting. Your fans may not come on with the AC if the PCM sees the compressor didn't come on.
willwren is offline   Reply With Quote
Old 10-04-2006, 06:17 PM   #20
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2006
Location: Seattle, WA
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
base1001 is on a distinguished road
Default

i have edited my last post.
base1001 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
hot hot hot jhill52788 1992-1999 2 07-07-2007 06:18 PM
replaced water pump found some oil in the water pump cavity cjpenny89 1992-1999 3 09-13-2006 12:15 PM
HOT HOT HOT! BonneMeMN Lounge 22 06-25-2005 12:46 AM
Feelin Hot Hot Hot LittleHoov General GM Chat 10 08-07-2003 01:41 PM
Getting new job.. getting paid, getting mods Wolfedog50 Performance, Brainstorming & Tuning 3 05-08-2003 02:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:37 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.