A/C Not working, is it the compressor? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-03-2007, 11:09 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
DaveSac11789 is on a distinguished road
Default A/C Not working, is it the compressor?

When i turn the A/C on, i know it doesnt just need a recharge, because the compressor doesnt even start up (unless its just EXTREMELY quiet, but i dont think so )
I dont want to go ahead and buy a compressor unless i know for sure that nothing else could be making the compressor stop..unless it is indeed the compressor itself
DaveSac11789 is offline   Reply With Quote
Old 03-03-2007, 11:23 AM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Please put your year and model in your signature. Depending on your year, you may be able to enter diagnostic mode on your ECC. We have no way of knowing if your compressor is good from the little information we have.

Do you have a 92/93 with the automatic climate control, or some other year or manual controls?
willwren is offline   Reply With Quote
Old 03-03-2007, 11:39 AM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
DaveSac11789 is on a distinguished road
Default

i have a 1993, manual controls
DaveSac11789 is offline   Reply With Quote
Old 03-03-2007, 11:50 AM   #4
Senior Member
Posts like a Turbo
 
Join Date: May 2005
Location: Fredericton, New Brunswick.
Posts: 380
Thanks: 0
Thanked 1 Time in 1 Post
Timothy's Buick is on a distinguished road
Default

Its very common for these cars to spring an AC leak at the evaporator. Hows the airflow to the vents?

Turn the front of the compressor, right in front of the pulley. If it turns, its probably not turning on due to low pressure. One way to check for sure, is to unplug the low/high pressure switch at the accumalator, and short the wires together (Paperclip?). Turn the AC on, and the compressor should spin up. If it doesn't, you'll need a schematic of the wiring to test for power to the compressor. If it does , the system is low on the refrigerant.
Timothy's Buick is offline   Reply With Quote
Old 03-03-2007, 11:57 AM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
DaveSac11789 is on a distinguished road
Default

great ill try that. thanks!
DaveSac11789 is offline   Reply With Quote
Old 03-03-2007, 12:10 PM   #6
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Quote:
Originally Posted by DaveSac11789
i have a 1993, manual controls
Please put your year and model (trim level) in your sig. Our responses to your posts will be much quicker and more accurate if we know what we're starting with to begin.
willwren is offline   Reply With Quote
Old 03-03-2007, 12:15 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
DaveSac11789 is on a distinguished road
Default

done. sorry i didnt realize i never did that!
DaveSac11789 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
98 AL7 compressor problems (not working at all) Killerzracing92 Everything Electrical & Electronic 14 03-22-2009 07:13 PM
A/C Compressor not Working lz1zjj 1992-1999 2 07-05-2008 12:49 PM
Radiator fans and AC compressor not working showshocka2k 1992-1999 21 03-15-2007 11:16 AM
1992 suspension compressor not working sse for me 1992-1999 9 07-14-2005 10:55 AM
Twilight Sentinel working then not working on '95 SSEi mrstangblb 1992-1999 1 12-03-2004 09:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.