abs/traction lights on - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-05-2008, 08:49 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Feb 2008
Location: blaine, minnesota
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
96bonneguy is on a distinguished road
Default abs/traction lights on

when i start my car they shut off like normal but when im driving they turn back on

abs light stays on

traction control light comes on saying that its off any way to fix it or just let it do its thing?

1996 bonneville se

i push the bottun but it stays on so it says "traction control off"
and abs light stays on except for when i turn off the car and restart it
96bonneguy is offline   Reply With Quote
Old 02-05-2008, 11:39 PM   #2
Senior Member
Posts like a Supercharger
 
Join Date: Jul 2007
Location: Wisconsin
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
Fast enough is on a distinguished road
Default

Had this happen to mine, it was I think the hubs had to be replaced. One one year, the next the next year.
Fast enough is offline   Reply With Quote
Old 02-06-2008, 06:38 PM   #3
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Feb 2008
Location: blaine, minnesota
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
96bonneguy is on a distinguished road
Default

i just had the hubs done about 10k miles ago bought the car with bads ones and told em the only way i would buy is if they replaced them for free at no cost to me
96bonneguy is offline   Reply With Quote
Old 02-06-2008, 09:51 PM   #4
Senior Member
Posts like a Turbo
 
Join Date: Sep 2007
Location: Saginaw, MI
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
TheDude is on a distinguished road
Default

You need to get it scanned and find out what the codes are. That will give you your base point to figure out what is causing the light to come on. It could be a bad speed sensro in the hub, or the hub itself. It could also be a wiring problem. The TCS sytem is tied into the ABS system. So when the ABS light is tripped, it will also trip the TCS light.
TheDude is offline   Reply With Quote
Old 02-06-2008, 10:42 PM   #5
Senior Member
Posts like a Supercharger
 
Join Date: Oct 2006
Location: Brooklyn, NY
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
Vas62 is on a distinguished road
Default

I got ABS and TC light today while driving and it was the belt slipped off the tensioner and knocked off in-link connector from the hub sensor.
Vas62 is offline   Reply With Quote
Old 02-07-2008, 05:27 PM   #6
Senior Member
Posts like a 4 Banger
 
Join Date: Jun 2003
Location: Minneapolis, Minnesota
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
TDS-94SSEi is on a distinguished road
Default

Yup, you've got a fault code in the ABS system that is triggering those indicator lights.

Likely a bad speed sensor in the hub. Will need a scan to pinpoint which one is reading incorrectly, and then you can check the wiring, and/or replace the hub if problem is not wiring-related.

So far I have not seen many problems with the system that are something OTHER than the Wheel Speed Sensors. Good Luck!!

For what it'* worth, the car will still drive and stop OK, but it will be just like an old car before those systems started to become popular.
TDS-94SSEi is offline   Reply With Quote
Old 02-07-2008, 05:32 PM   #7
Junior Member
Posts like a Ricer Type-R
 
Join Date: Jan 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
88Mustang is on a distinguished road
Default

Same thing has been happening to me. I scanned it and it says there is nothing wrong. If I turn the car on and off it goes off, sometimes it will come back on 5 minutes later, other times it won't....What is my problem here? Thanks
88Mustang is offline   Reply With Quote
Old 02-07-2008, 07:57 PM   #8
Senior Member
Posts like a Turbo
 
Join Date: Sep 2007
Location: Saginaw, MI
Posts: 345
Thanks: 0
Thanked 0 Times in 0 Posts
TheDude is on a distinguished road
Default

Quote:
Originally Posted by 88Mustang
Same thing has been happening to me. I scanned it and it says there is nothing wrong. If I turn the car on and off it goes off, sometimes it will come back on 5 minutes later, other times it won't....What is my problem here? Thanks
What year is it? Some of the computers will store the codes in the memory, other wont. On the older ones, you need to scan them while the code (or light) is present. Otherwise it will reset itself until it gets tripped again.
TheDude is offline   Reply With Quote
Old 02-07-2008, 08:48 PM   #9
Junior Member
Posts like a Ricer Type-R
 
Join Date: Jan 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
88Mustang is on a distinguished road
Default

Quote:
Originally Posted by TheDude
Quote:
Originally Posted by 88Mustang
Same thing has been happening to me. I scanned it and it says there is nothing wrong. If I turn the car on and off it goes off, sometimes it will come back on 5 minutes later, other times it won't....What is my problem here? Thanks
What year is it? Some of the computers will store the codes in the memory, other wont. On the older ones, you need to scan them while the code (or light) is present. Otherwise it will reset itself until it gets tripped again.
Sorry it is a 1997 SSEI...When I came home today from school I left the car running and went and got the scanner. I scanned it and it said nothing. It doesn't happen all the time. Just sometimes. And when the light does come on neither the abs or traction work. Sucks as this is my winter beater. I need the abs + traction for winter.

summer time is the stang
88Mustang is offline   Reply With Quote
Old 02-08-2008, 01:01 PM   #10
Senior Member
Posts like a Turbo
 
Join Date: Jan 2008
Location: Memphis, TN
Posts: 281
Thanks: 0
Thanked 0 Times in 0 Posts
93RedSled-SSE is on a distinguished road
Default

Sideways here:
If you run out of options; I had problem with the ABS lite staying lit. It turned out to be that octopus looking ABS controller (valve?) that is in the front of the engine bay, on driver'* side. Junkyard price here was about $175 (close to $800 rebuilt). My brake guy charged $120 to install, but was worth it.
Hope it is not that, though.
93RedSled-SSE is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I Fixed the lights the wipers and the traction contol lights abs and brakes 2000BLKBONNEVILLE Everything Electrical & Electronic 0 09-22-2009 10:30 PM
ABS/Traction light on...but i still have ABS ptrfair 2000-2005 0 12-11-2007 08:33 PM
Traction Control & ABS lights xX1SSEI1Xx 1992-1999 3 06-13-2005 10:45 PM
ABS/ Traction Off lights DDay 1992-1999 6 07-30-2004 11:52 AM
ABS & Traction Control Lights al 1992-1999 6 01-23-2004 11:24 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:20 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.