ABS AND Traction control light on - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-28-2004, 11:47 AM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: Jan 2004
Location: Chicago,IL MWBF '04 SURVIVOR MWBF '05 SURVIVOR Napa Manager
Posts: 3,955
Thanks: 0
Thanked 0 Times in 0 Posts
Kennginn is on a distinguished road
Default ABS AND Traction control light on

does anyone know what that means when both are on???
Kennginn is offline   Reply With Quote
Old 05-28-2004, 12:36 PM   #2
Senior Member
Expert Gearhead
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default

*stab in the dark*

ETCBM.. (Electronic Traction Control Brake Module) essentially the ABS brains. .go get a mortgage they wanted $1100 CDN for that part on my car
Jim W is offline   Reply With Quote
Old 05-28-2004, 12:53 PM   #3
Senior Member
Posts like a Northstar
 
Join Date: Jul 2003
Location: Georgetown, Ontario
Posts: 679
Thanks: 0
Thanked 0 Times in 0 Posts
Baileyjack is on a distinguished road
Default

On my 94 SE when that happened it turned out to be my wheel bearing. It ended up costing me about 500.00 when done with a lifetime warrenty on the bearing
Baileyjack is offline   Reply With Quote
Old 05-28-2004, 01:03 PM   #4
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

EBCM or EBCTM is a remote possibility at best. I've yet to see one fail. Most likely culprit is one or more wheel speed sensors or associated wiring (not the bearing as stated, either, but the sensor is an integral part of the hub assembly), or the PMV (another very expensive part).

Diagnosis is Dealer-only (special serial reader) and usually costs a minimum of 80 bucks. I suggest you inspect the wiring to all 4 wheel speed sensors first.
willwren is offline   Reply With Quote
Old 05-28-2004, 01:17 PM   #5
Senior Member
Posts like a Northstar
 
Join Date: Jul 2003
Location: Georgetown, Ontario
Posts: 679
Thanks: 0
Thanked 0 Times in 0 Posts
Baileyjack is on a distinguished road
Default

OOPS! Sorry forgot to also include that when my ABS and Traction Control Lights came on the ABS kept coming on. Id be driving about 10 kph all of a sudden the ABS would come on.
Baileyjack is offline   Reply With Quote
Old 05-28-2004, 04:11 PM   #6
Senior Member
True Car Nut
 
Join Date: Jun 2002
Location: Bedroom, Ontario
Posts: 3,266
Thanks: 0
Thanked 0 Times in 0 Posts
Drifter420 is on a distinguished road
Default

I think the ABS just comes on initially when in motion for self diagnostic purposes.. definitely check the wiring and speed sensor hub/bearings.. I have the exact same issue.. just broken wire going to rear passenger side wheel bearings that'* broken.. and too lazy to fix.
Drifter420 is offline   Reply With Quote
Old 05-28-2004, 05:45 PM   #7
Senior Member
Posts like a Turbo
 
Join Date: Jul 2003
Location: Markham, Ontario, Canada
Posts: 239
Thanks: 0
Thanked 0 Times in 0 Posts
faisalmali is on a distinguished road
Default

I also have a 97 Transport. The ABS/Traction Control light comes on in rain only. Could that be a loose wire or sensor that gets wet?
faisalmali is offline   Reply With Quote
Old 05-28-2004, 11:52 PM   #8
Senior Member
True Car Nut
Thread Starter
 
Join Date: Jan 2004
Location: Chicago,IL MWBF '04 SURVIVOR MWBF '05 SURVIVOR Napa Manager
Posts: 3,955
Thanks: 0
Thanked 0 Times in 0 Posts
Kennginn is on a distinguished road
Default

Quote:
Originally Posted by willwren
EBCM or EBCTM is a remote possibility at best. I've yet to see one fail. Most likely culprit is one or more wheel speed sensors or associated wiring (not the bearing as stated, either, but the sensor is an integral part of the hub assembly), or the PMV (another very expensive part).

Diagnosis is Dealer-only (special serial reader) and usually costs a minimum of 80 bucks. I suggest you inspect the wiring to all 4 wheel speed sensors first.
since i work at napa the diasnostics is free and i was told front left speed sensor will b fixed with timin chain this weekend
Kennginn is offline   Reply With Quote
Old 05-31-2004, 09:49 AM   #9
Senior Member
True Car Nut
 
Join Date: Jun 2002
Location: Bedroom, Ontario
Posts: 3,266
Thanks: 0
Thanked 0 Times in 0 Posts
Drifter420 is on a distinguished road
Default

Quote:
Originally Posted by faisalmali
I also have a 97 Transport. The ABS/Traction Control light comes on in rain only. Could that be a loose wire or sensor that gets wet?
Sure sounds like an open wire and or loose connector. ( That would be my first guess ) since when it rains.. if you're wire is open.. it'* shorting itself somewhere. The other thing I can think is the speed sensor has a leak somewhere allowing water in. Check wires/ connectors first.. they're the easiest and cheapest.
Drifter420 is offline   Reply With Quote
Old 05-31-2004, 09:53 AM   #10
Senior Member
Posts like a 4 Banger
 
Join Date: Feb 2003
Location: Mississauga, ON
Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
sterdeus is on a distinguished road
Default

I have the same issue. ABS would engage at any time.. and would eventually disable itself and set the ABT and TC lights to come on. My cousin and I (actually it was all my cousin.. I just watched) diagnosed it to be a sensor.. and just happens to be the same one that the wheel bearings are making noise. Maybe the wheel bearing failure caused the sensor to malfunction as well. Anyway, my question is, what size is the main hub bolt?? We've had reports or 33mm or 36mm.. does anyone know? Thanks
sterdeus is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ABS/Traction light on...but i still have ABS ptrfair 2000-2005 0 12-11-2007 08:33 PM
Stability Control System-ABS-Traction Control compyelc4 2000-2005 16 03-06-2007 11:03 PM
abs light and traction off light are on silentfrwy 1992-1999 9 09-28-2004 04:51 PM
Traction Control and ABS DieselChris 1992-1999 6 12-18-2003 12:00 AM
ABS and TRACTION CONTROL light stays on kerker 1992-1999 11 05-13-2003 10:23 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.